Odd lighting artifact

Check out the highlights on the lower leg straps -



The highlight disappears without the body model -


As far as I can tell the problem has to do with the interaction between the main overhead light, the straps, and the body. Take that light out, or the body out, and it’s fine. Put them together, the problem shows up. Turning off SSS makes no difference, turning down the intensity of the light makes the artifact less bright, but it doesn’t go away. It doesn’t make the highlights look the same as when the body is hidden.

Here’s the .blend - Link

Using “Full Sample” in anti-aliasing options solves this :slight_smile:

*btw I was amazed that this scene renders in 3 seconds nice lighting.

I’m amazed too, it takes my machine 23 seconds. What are the specs of your machine?

I’ve been away from Blender for a few years, drawing the comic this character is from. It’s only black and white line art, but I must have composed around 800 “shots.” It helped.

Full sampling solved the problem right?

Oh, I just threw that “3 seconds” out of the blue without actually checking the time. It takes 5-7 seconds depending on the AA settings :stuck_out_tongue: My CPU is Intel i7 3820, 4,3 GHz turbo :slight_smile:

I’ve noticed this with other things as well, I had a text object with a shadow, and part of the background shines through the antialiased edge between the model and the shadow. You can see in your shot that the weird outline only appears when the background is light. Above that, it is black, where the background is black.
Good to know Full Sample solves it, but I’m still confused why this happens.

Yes, “full sample” solved the problem. Thanks!

I don’t recall “full sample” being in the pre-2.5 versions of Blender. So much to learn about the new one. I accidentally discovered the “scopes” toolbar while rendering last night. I have no idea what to use that stuff for.