Off-set bone for different actions in NLA [?}

Hi there potential helper. I have a few actions with repeats + an OffsBone Torso bone in the NLA. My character walks or runs forward and all works as expected, the root bone jumping ahead with each repeat. When I try to combine actions is where the headache begins. The problem is with each action the root wants to begin at the same position 0,0,0 [xyz]. I thought I could work around by repositioning the root at the identical position as the transition, which almost worked - the movement continues as desired, but exactly between the strips (there is no gap) Blender does this flash of freaky mesh = it still wants to reference 0,0,0 before continuing happily. No amount of Blending in or out, adding or holding has helped…hence this plea. Anyone got a clue?

p.s. I tried repositioning the feet roots and Torso to the transition points too with no more success…

Yeah I’m trying to figure this thing out too.

To prevent the character from starting over, I put the last NLA strip ( the walk one ) to hold. Then I added the new action after the walk strip. Only problem is I’m still getting a bit of a ‘jump’ between the strips, by only a few units, enough to make it look bad.

I hope that’s a start, let’s see if we can figure this out!

I wish i had gotten that far. I am stuck at having only one strip play, when i duplicate the strip then only the active strip animates the character and not active strips do not do anything. Can you guys help out in what is going on ?

  j 	I wish i had gotten that far. I am stuck at having only one strip play, when i duplicate the strip then only the active strip animates the character and not active strips do not do anything. Can you guys help out in what is going on ?

That means your in Action Mode, not NLA mode. Go into the NLA window, and click on the Action Editor Icon to toggle it into full NLA mode.

Ok so I just stopped using the blend feature. I couldn’t get it to really ‘blend’.
Instead I just stopped the strip at one frame, and began the next on the next frame, no overlap, so there’s a bit of a sub-frame ‘gap’ between the strips. I basically have to eyeball the two animations so they transition into one another, its not as hard as I thought it would be.

So I have my character walk along a path, stop and do some stuff, then continue on a different path. The first walk is on one path, the second walk on another path. No blending or holds or Adds, just one strip after another. This seems to be the least problamatic setups.

Thank you. Took me while to figure what to toggle but now I got further in making a use of the editor, thanks again

just got the blending of two strips to work quite good. both have add on and the other auto-blending, the other set blending time. Maybe that will work for you also.

I made a walk cycle and a run cycle, which I presumed I could blend. When that didn’t work I tried to make an action between - a transition from walking to running. In theory it almost works, were it not for the in between frame flash. I could render a frame sequence and delete the blip frame, but that seems like a really clunky way of working. Suspect I should try animate this differently…

Glad you got it to blend j, I couldn’t! But I have some stuff with a path modifier blending into a non-path action - maybe that’s why. And I can’t put this other action on the path, otherwise I can’t fully pose the rig.

@ patdog - yeah I know I think I need to animate differently too. Its almost like what my rig needs is the offending bone ( the one jumping ) parented to another bone that isn’t in the action strip. Then create a ‘bridge’ action strip between the two original action strips with that new parent bone and animate ‘over top’ of the other two.

I’ll try that.

I struggled with this sort of thing for a while, and couldn’t get any useful answers for that particular part of animation (I am fairly new to this, and have stopped animating uintil I can model and rig a little better now). The general scheme I came up with was:

  1. make sure everything (path, mesh, armature) are properly aligned or you will get weird deformations or facing the wrong way down the path and animating but not following the path
  2. remember to check if you are in action editor for editing actions, or NLA for actually seeing the finished result
  3. use the deform modifier with a curve rather than following a path
  4. select the hold option with the NLA strips
  5. either animate the whole thing by hand (don’t use walk cycle) if you are doing short things (e.g. only 2 or 3 paces) or do ‘fill-in’ animations
  6. to fill in, use the buffer to copy poses, e.g. walk cycle then run cycle: do walk cycle. When finished, copy the first frame pose into the buffer. Do run cycle. Copy the first pose of the run cycle into the last frame of the ‘walk-to-run’ action. Fill in however many steps you want in between the two and adjust the poses as needed to look more natural. You could have e.g. a walk cycle, followed by a stand and scratch your arse animation, then a run cycle. As long as the first and last frames of each match up, the transition should be smooth (if there is a slight halt because the last and first frames are the same (i.e. held for two frames) then key all the bones in the 2nd to last frame then delete the last frame so that the transition is smooth (make sure to copy the last frame first to the first frame of the next sequence).

The offset bone just tells blender where the figure is moving relative to the path, so animating a stand is not a problem, as long as you use the deform modifier and NOT curve follow (access via the properties menu, same as the ‘hold’, ‘add’. blend in/out buttons.

Clear as mud?