Offset Edges Addon not working with Blender 2.79


(Vince Bly) #1

I installed the edge offset addon from a saved file and enabled it in Blender 2.79, but it doesn’t show up. I’ve used it on previous versions of Blender with no problems and currently have 2.78B on my notebook. There was a note of some issue with 2.79 on the GitHub site, but I could find no further information.

Below you will see the mesh edges menu for 2.79 with no offset edges and a section of the addon list in the User Preferences that shows offset edges enabled. I’ve also included the mesh edges menu from Blender 2.78B which does show the offset edges options. Both systems are running Win 7 Pro SP1. The version of the Python script is 026.

Attachments





(Cyaoeu) #2

I tested it in 2.79 and it worked for me. Do you see anything related to offset edges in the system console? (Window - Toggle System Console)


(Vince Bly) #3

Hi Cyaoeu,

No, I don’t see anything in the system window except: “Read prefs: C:\Users…\2.79\config\userpref.blend” and “found bundled python: C:\Program Files\Blender Foundation\Blender\2.79\python”. 'Just the usual stuff, I think.


(Cyaoeu) #4

How did you download it and where is it in your addons folder?


(Vince Bly) #5

Hi Cyaoeu,

I got it from a .zip file attached to a Blender Artists topic in 2013. The link is: https://blenderartists.org/forum/showthread.php?304353-Addon-Offset-Edges
It was in: … \Blender\2.79\scripts\addons\mesh_extra_tools\mesh_offset_edges.py

Based on your question, I tried another version of the script that was in: … \Blender\2.71\scripts\addons\mesh_offset_edges.py

I don’t know if the issue was a corrupt file in the 2.79 folder or if it was being in … addons\mesh_extra_tools rather than just addons, but that fixed the issue!

Thank you for your help on this. :slight_smile:


(Cyaoeu) #6

A bit strange that you’re using an old version, probably a better idea to get it from the guy who made it: https://github.com/Bombaba/BlenderPythonScripts
Download the zip and extract the file to the \addons\ folder.