Old links to individual posts don't resolve

high-priority

(joahua) #1

Ok, I feel a bit ignored here with my feedback regarding the migration to Blender Artist 2.0. So I apparently have to flesh it out:

On the second day of the Kickstarter campaign (to get funding for a full migration to Discourse), I asked the new administrator:

Joahua:
I have over the years collected a fair amount of links to good/interesting BA post’s. So here is a quick question :

If the crowd-funding campaign succeeds, and a a full migration of Blender Artists from vBulletin to Discourse follows. Will links for old BA post’s still work ? (aka. not be broken).

And the new administrator answered:

B11 [email protected]
Yes absolutely.

So that is very clear - links to specific old BA post’s will not be broken if the migration gets fully funded.

When interesting threads often becomes very long (with hundreds or thousands of post’s), just linking to the first post in a thread is of course not having a unbroken link to a specific post.
But right now this is how things are in BA 2.0. Specific interesting post’s I have collected (and I have a lot) are redirected to post 1 in the thread.

So that leaves two scenarios:

A. This is a technical glitch in the migration. It will be fixed over time.

B. The promise that links to specific post’s would not be broken - was a promise made during the crowdsourcing campaign that are not being kept.

So what is it - A or B ?


Known issues with the new site
(Bart Veldhuizen) #2

@pfaffman could you comment on this? Can we generate rewrites for individual posts in migrated topics?


(pfaffman) #3

I believe that on the site links in posts have been replaced with links to the post that they linked to, but that external links from outside the site resolve only to the topic, as the point of those links is to maintain SEO juice.


(Bart Veldhuizen) #4

I don’t think I’ve seen any examples of rewritten links to imported posts; they’re all still in the original format.


(pfaffman) #5

Hmm. Can you give me examples? This can be fixed in place.


(Bart Veldhuizen) #6

Sure. Here are a few I dug up with the search function: none of them have been replaced with new ‘Discourse style’ links:

Not working

Links of the format http://blenderartists.org/forum/showthread.php?t=xxxx.

Working

Links of the format https://blenderartists.org/forum/showthread.php?339369-MultiEdit-version-5-Multiple-Objects-Editing

@joahua could you provide some examples of ‘deep links’ that point directly to an individual post down a topic?


(joahua) #7

Here u go (from a earlier post):

it’s post 262 & page 14 in the old BA - post 258 in the new BA

It’s post 268 & page 14 in the old BA - post 260 in the new BA


(joahua) #8

Hi Bart

Are there any ETA on when you will get around to fix this issue ?


(joahua) #9

Hi Bart

I’m writing again to hear if you can give a estimate on when this issue will be resolved ?
(I also wrote 1½ month ago - but it was in the middle of summer vacation time, so understandable that I didn’t get a reply then)

I have also discovered that at least one old BA thread is missing - Blender UI Mockups and Ideas Requested.
I realised this when I wanted to link to a old splashscreen design concept I had posted on BA in the past, to developer.blender.org - topic : Blender 2.8 Splash Screen Design. Here William Reynish are asking for feedback and ideas for a updated splashscreen for Blender 2.8.


(<== Lost? Click Me) #10

Hi, this is the latest I saw about missing threads:


(joahua) #11

Thanks for info…


(joahua) #12

Hi Bart

I have waited - before I posted here again - until after the BlenderArtist talk at the recent Blender Conference. In case we were given some relevant information at that occasion.

But no, this was not the case. So I’m writing now here to ask (again) if you could give me a ETA on when this problem will be fixed ?

And I hope that you have the time to answer this now. I’m a bit puzzled that this ‘bug’ is labelled as high-priority. But it have not been a priority to give a answer to my request for some kind of a ETA.


(Bart Veldhuizen) #13

I have just posted a final update:


(joahua) #14

@Bart

As you know we have discussed this issue today trough PM. I’m switching now to this thread, since this is the appropriated place.

If I understand you correctly, the new BA could not handle all the information involved in having direct links to old post (so it is just directing them to the OP in a given thread).

Just to summarise, this is from my first post in this thread:

So is it correctly understood that we are looking at scenarie B ?


(Bart Veldhuizen) #15

I’m sorry but that is correct - in the end we were not technically able to link to specific posts within topics from the old Urls.