One of my animations assumes the pose of the last animation I viewed?

I have an Attack animation that I finished and then went ahead and added a new animation, renamed it Dead and made my dying animation just dandy. However, when I went back to my Attack animation, it was constantly stuck in the last frame of the Dead animation. I then went to my Idle and Run animations and switched to my Attack and the pose was that of the frame I was in in the Idle/Run.

So to be clear about the Attack animation:

  1. The pose does not change, no matter how I move the green bar
  2. The pose it seems to be “stuck” in is the last pose I viewed in any other of the animations.
  3. It has all the keyframes (and by keyframes I mean the diamonds) in the exact order/positions it originally did.

What is going on? :frowning:

SOLVED: The F-curves of the channels were locked and by going to Channel > Revive Disabled F-Curves in the Action Editor, the problem has been resolved! See this:

By “switching” your animations I’m assuming that you select different pre-made Actions from the Action Editor list. If all but the Attack Action work OK, then check to see if any of the icons that will disable the animation channels have been inadvertently clicked in Attack. These can be found in the Action Editor as well as in the Graph Editor. If your animation channels have been disabled, you’ll still see the keyframes but they will have no effect on the armature/object, so it will retain whatever pose was last active.

In 2.61 these enable/disable icons look like little speakers – if no “sound” (little soundwave symbols) is coming from them, they are disabled. The tooltip is “Do channels contribute to the result.”

I checked the speaker things and they were all fine (you can see the audio waves coming out of them).

However, what I did notice was that when I expanded any channel in the Attack animation, all the entries were underlined red. I checked the same things for the working animations and confirmed there was no red underlining. I’m guessing this is the issue, but I have no idea what to do about it.

Edit: Annnnd a quick google search revealed that the F-curves were locked and by going to Channel > Revive Disabled F-Curves in the Action Editor, the problem has been resolved! Thanks for the tip chipmasque!

Are you playing with the NLA? If so, look at the strip and enable editing (pressing tab I think)