Onion skin not working on new layers!

Help! My onion skin was working fine until it stopped working on one layer. I added a new layer, but it’s completely stopped working! I’ve tried everything I can find. Please help!

Which onion-skin addon are you using?

I’m not sure, how can I check?

Open Preferences, go to the Addon tab, and in the search field, type ‘onion’ and see what comes up.

Nothing appears to be coming up. That’s strange, I have access to an onion skin tool but there’s no add on?

are you talking about grease pencil onion skin?

Yes, Blender greaspencil, onion skin.

Can you provide a part of the" bugging file". Because, sayed as you told it to us, it’s really difficult to find any clues about the problem.

Default onion skin layer config:

Well, It’s hard to show. There isnt a clear ‘bug’ It just isn’t working on the new top layers. (AAAAA and Lineart 1)

They seems to be hided… (eye icon) in your example. Is it working showed?

Oops! Left it off. But yeah, it’s still not working showed.

did you try it on another blender version than your build?
i’ve tryed with 25 layers and nothing wrong for me. 2.93.4

I’ve got 2.91.2. I’ll update it then let you know if it worked!

Since you are updating, there was a change that might confuse you. If you aren’t aware of it.

Also I’m betting updating should fix the onion skin problem. As I remember seeing a bug report that was similar get fixed for 2.93

1 Like