Onlyshadow question

Yesterday I was having a heck of a time getting onlyshadow to work in a scene. I searched the forum and the web and read a number of posts and one of Wierdhat’s tuts (thanks!) but it seems my settings were all right? I’ve been experiancing lots of little problems like this ever since upgrading to 2.42, Just nothing reproducable enough to be bug worthy.

So this morning I created a simple scene to try and figure out how onlyshadow was working. First it seems that turning on tracable breaks onlyshadow now. Also alpha controls the darkness/transparency of the shadow. Last it doesn’t matter if you have shadow on or off when onlyshadow is on.

Okay, now the question: My onlyshadow object doesn’t occlude light/shadows from reaching objects under it (which makes sense), but I don’t want two shadows from one object. So how do I stop the shadow on my onlyshadow object from casting a shadow on things under it? I’m guessing I need to use duplicate lights on seperate layers to avoid this, but is there a cleaner option?

Example image:
and Blend

OK, first off… Don’t confuse OnlyCast with OnlyShadow.

It’s behaving exactly as it should, what did you want it to do? A shadow to fall on a transparent object, but only strike it on one face and stop? Err… uhm… err… :stuck_out_tongue: I guess making it opaque isn’t an option?

Also remember if you’re not confusing OnlyCast with OnlyShadow that OnlyShadow affects the alpha channel not the rendered scene… 3a is the scene, 3b is the alpha channel; eg. what you expected to see?


My point was how do you then stop the shadow before it hits the plane. My current best answer is to duplicate the light source and move it and my shadow reciever to another layer, then set the light to layer(only).

I’m asking about this for use in compositing, where my only shadow object would be a proxy for an object in a photo. So if you had a table and a floor and you wanted to set something on the table your CG object would cast a shadow on the table AND the floor at the same time :rolleyes:

No, only if the receiving object is translucent or transparent. Look at #2. I specifically left it off-the-edge so you could see the effect. If you’re compositing against transparency, yes, you’re going to have a problem. If you’re compositing with alpha then you shouldn’t.

In your example, if your table was wood, you’ve got no issues. If your table is glass, then hey, there IS going to be a shadow on the floor too. If that’s the case your solution is the best one. (Remember to Alt-D the light, not Shift-D… you want adjustments on one to track the other.)

Footnote: DAMN! I was trying to make an example image for you using the table scenario, and discovered a weird buffer shadow that seems to X-Ray completely opaque objects. Grr. :frowning: See the thread “what’s up with this shadow?”

I have a question related to shadows, how do you make something not emit a shadow? I have seen to make things only emit shadows, but no option to stop emiting a shadow, yet there must be something I am missing… Can anyone help? Also, sorry for the slight off topic post, but I didnt want to make a thread for such a basic (IMO) question that I cant seem to find the answer too.

Thanks for your time. Have a good day

in the “shaders” bit of your material, there are buttons that say “shadow”“trashadow”“onlyshadow”“bias”
uncheck “shadow”