oops, cant find armatures

I was creating my vertex groups, so I selected a bone layer that had no bones on, to hide the armature, and then selected my object mesh, now I cant figure out how to display the bones again, because the only way I know how is to select the bones using the mouse

make sure you are showing all the bone layers (it might be on a layer that is not visible)

you also might have hidden it by mistake - press alt H (with all layers visible)

you can also select bones through the outliner

thats the thing, I cant seem to find the buttons where I can select the correct armature layer, since I deselected all of them, that seems to have hidden itself :o

see the display option buttons make sure you shift select them all