Open VDB/voxel hopping in Eevee

Hello fellows. I hope you’re doing well.
I have an issue with rendering volumetrics/openVDB in eevee, and I’m hoping you can help me figure it out.
On frame 203, things are fine.

on frame 204, the smoke suddenly leaps away from the flames a great distance.

This is not an issue in the viewport preview, nor in cycles, nor in Houdini where I initially baked the explosion.

proof that the problem does not exist in cycles:

This is not the first time I’ve had this issue with volumetric simulations in Eevee, it’s atleast two years old at this point, previously with simulations baked in blender with mantaflow, and I’ve never been able to find an answer searching the web.
I’m using blender 3.3, I’m currently on a macbook air M1, but have had this issue on an old intel macbook pro, and a windows PC with an AMD CPU and a geforce 1080, so I don’t think its platform specific. I’m hoping there’s just some setting I’m missing.

I’ve tried adjusting the volumetric clipping ranges, the tile size, the samples (render samples, volumetric lighting samples and shadow samples), distribution, light clamping. Turning off volumetric lighting does remove the hopping smoke in this case, but only by completely removing the smoke.
Changing the density in the material settings also does nothing.
There is no animation data on the volume objects.
Applying scale does nothing.

Any help would be appreciated. Thanks for taking the time to read this post.

Okay, I did yet more googling, and it looks like this has actually been addressed as a bug fix in the latest version of blender. Thank goodness.
Here’s a bug thread for it,
And updating to the most recent version of blender seems to have fixed it for me, and thankfully, it looks like I don’t have to reinstall and re-enable addons when I update blender now, hurray!