opensuse 10.3 blender issues

hello all

im have a problem getting blender to work on opensuse 10.3

  1. when i switch to camera view, the camera is black, then blender crashes

  2. same with material view, as soon as it open, it crashes (camera is black)

  3. soon as the scripting window is opened, blender crashes.

ccsm is not istalled

blender ver. 2.44.43
download ver 2.45 same issues

any help would be greatly appreciated
thank hutch


I don’t recognise the problem, I’m running opensuse10.3 here too. I have however, had some problems crashing the game engine due to some irregularity with openGL. It’s not the same issue as you, but maybe it’s related.

Can you give a few more details? Maybe we can narrow it down a little.

Are you running 32 or 64 bit suse?

Do you get any error messages if you run it from a shell? I’m guessing segfault, but any messages that pop up would be handy.

What graphics card & driver?

Also, you mention ccsm not being installed, do you have compiz then? If so, have you tried running blender without it?


32 bit
all i get is segmentation fault
ati raden
i have ccsm in one of my addon repositories but i never install it

i had the same errors on ubuntu studio

That you had the same errors on a different install would suggest a driver issue.

Can you give the actual graphics card name (like the ati radeon X4583 or whatever)?

Also, if you can find out the graphics driver, and maybe try updating it, that’s the most obvious next step.

i have ccsm in one of my addon repositories but i never install it

So thats a no to compiz (or other eye candy type things)? As far as I can tell, ccsm is just a settings manager.

ati radeon 9250

driver: rv280 5960

the driver is correct

10.2 used 5900, and i had no problems with it.

Have you ever compiled blender before? If so, might be worth cranking out a debug build and running a backtrace after the segfaults.

10.2 used 5900, and i had no problems with it.

Driver version 5900? Any major changes between that and 5960? If not, or even if so but is easy to do this, might be worth trying the old driver and see if that works. Try and narrow this down as much as possible.

the driver is correct

Might be a matter of opinion there :stuck_out_tongue:

thanks for your help. im getting frustrated now. so im going to install windows and drop linux for now

heh heh, after six hours and not even trying with the old driver that obviously worked well.

well have fun.
thank god there never are any problems on windows.


I had this EXACT same problem on Ubuntu 7.10. It was a driver problem with my Radeon 9250. Apparently, a Mesa bug which is being looked at for the next version. I gave up in the end and bought a Nvidia card which has solved all of my graphical problems on windows AND linux :smiley:

same problem here.

Ubuntu Studio 7.10
Radeon 9250

any fix on this?

Try driver version 5900.

hi all!

just want to share this.
If you have ati radeon 9250 and wants to use Linux. I think Debian Etch is the way to success. Because the closed source driver by ATI which is “fglrx” is already available in the synaptic. Just few installations and everything is up and running.

Other Linux distro that can use “fglrx” in an ati radeon 9250 card is Ubuntu 6.10 (Edgy Eft) because it is still using Xorg 7.1. But new versions of Ubuntu like Ubuntu 7.04 (Feisty Fawn) and Ubuntu 7.10 (Gutsy Gibbon) will just lead to a broken system because it is already using Xorg 7.2, and needs to downgrade to 7.1 to have “fglrx” running (maybe, I tried it but it won’t work on me).

I also tried Fedora 8 and the problem “when i switch to camera view, the camera is black, then blender crashes” is not there. Blender is working all good in Fedora 8, but of course you must use the default driver.

I’m currently using Debian Etch with “fglrx” and it’s really stable than any versions of Ubuntu.

Hope this may help some. :slight_smile:

Debian etch is “hard rock”…if you don’t add packages from “lenny” or “sid”
you have, probably, the most stable os available?!