Ortho views, locking & camera border in viewport


(jonsandbox) #1

Okay, so I know this has got to be basic. But I’ve been doing web searches, looking through wikibooks “Blender noob to pro”, and going through 10+ threads here on BA, but I can’t seem to find an answer.

Question 1:
In the viewport, how do I lock orthographic views so I can’t rotate into a 3D persp view by accident?
In quad view, I can check “lock to 3D cursor” but when I’m fullscreen in an ortho view, I can still accidentally rotate into a 3D perp view.

Question 2:
Is there a way to remove the dotted redline for the camera border? I like being able to hit Render any time and get a preview of the exact view I’m working in, but the red line is a little distracting.

[ATTACH=CONFIG]384918[/ATTACH]

Stats: Blender 2.70 Win XP 32 Pentium 4 Graphics card, I believe, is whatever came with machine

Thank you in advance if you’re able to respond.


(Thies Schulz-Holland) #2

Make sure you have “Auto Perspective” turned off in the user preferences:


Not sure if there is a way around this. That dotted red line is there to make unmistakably clear that you have “Lock Camera to View” enabled. If you could turn that off, it wouldn’t be much of a warning…:wink:

Perhaps you can give this a less intrusive color in the theme settings?


(wellerankanto) #3

I just noticed that you can (h)ide the camera, even in camera view. That will make the dotted camera view border less noticeable (it turned dark grey or black in my blender, but I use a heavily customized theme).


(jonsandbox) #4

IkariShinji and wellerankanto,

Thank you for the replies, I appreciate the tips.

  1. I tried the turning off Auto Perspective, but I’m still able to accidentally rotate an ortho view into 3D persp. I would think there would be some way of locking the view. Maybe there’s an addon that does this. I’ll give that a look.

Any other ideas on how to lock ortho views?

  1. For hiding the camera, is that the same as “toggle visible?” I know that sounds obvious, but I’ve found different apps have different definitions.

Good point about the themes. I’ll try that next.

Again, thank you.


(jasonschleifer) #5

Ah, thank you so much for this!!

Auto Perspective was driving me batty! :slight_smile:

Cheers for the tip!

-jason


(jonsandbox) #6

So I’ve been looking a lot online and on BA for scripts that would lock viewports. No joy.
I’ve found viewport snapping, but that isn’t quite it.

Is there any possible way to prevent rotation or accidental switching to perp views in an ortho view? When the ortho is maximized is especially when I would need it.

Is there a way to disable the MMB in the 3 orthos but not in the user persp?

Any tips or ideas, even if you’re not sure, would be most appreciated.

Thanks.


(Thies Schulz-Holland) #7

There seems to be an issue with terminology that perhaps stops people from understanding you correctly (I know it happened to me):

By “ortho” view you mean one of the six aligned (“straight on” = front, left, top etc.) views, correct? And with “persp” view you mean any non-aligned (“user”) view in the viewport?

That’s actually not what orthographic and perspective mean. Any of the views can be either orthographic or perspective: If it uses a realistic vanishing point projection it is called perspective view. If it doesn’t, it’s an orthographic view (toggle with Numpad-5).

http://wiki.blender.org/uploads/thumb/8/82/Manual-Part-I-3DPerspective.png/630px-Manual-Part-I-3DPerspective.png

So basically you want to disable viewport rotation - but only if you are in an aligned view. Tricky, I would assume…

May using quad view (Ctrl-Alt-Q) be an alternative for you? AFAIK the three aligned viewports in quad view are locked: They can be panned and zoomed, but not rotated.


#8

What you are experiencing should not happen unless you have Auto perspective enabled.
Disable it and save user settings otherwise next time you open blender it will still be enabled.
Maybe it’s a keyboard problem stuck key.
Even in Quad view when you unlock it you can still rotate the views in ortho mode.


(Kurtis) #9

You can turn off the render border altogether by hitting ‘Ctrl + Alt + B’ but it’ll render in its entirety rather than just the region you selected.


(Thies Schulz-Holland) #10

Yeah, but that’s exactly what he doesn’t want. The OP wants a “Lock” checkbox (like the one for the Quad View) for the single viewport, which results in viewport rotation being disabled as long as the viewport is in an orthographic aligned view (front, back, left, right, top, bottom).


#11

I got that @@IkariShinji but till post #4 he was asking how to stop rotating in perspective view while in ortho hence my response.


(Thies Schulz-Holland) #12

…because for him
user view = “perspective view” and
aligned (Numpad-1,3,7) view = “orthographic view”.

I didn’t get that at first, too, so welcome to the club…:wink:


#13

If he wants that he can temporarily disable the 3d view rotation.



(jonsandbox) #14

Terminology
Thanks for the point about terminology. Looks like I was thinking in the verbiage of other 3d apps; LW, modo, Maya.
I definitely get being able to flip into and out of a perspective camera or an orthographic camera (which is a handy thing that most apps don’t have).
From LW, modo, and Maya I’m used to a quad view where there’s one perspective viewport, and the other three Front, Top, Side viewports are locked in as strictly orthographic. But a better way to describe it would be that I want to disable rotation in any viewport that is a straight-on ortho camera.

Auto perspective
I tried that a few times, saving the settings each time. But even if I restart Blender, confirm auto persp is off, I can still rotate one of the Front Ortho, Top Ortho, or Right Ortho views.


(jonsandbox) #15

Okay, so following ramboblender’s point about disabling rotate view, I changed “Rotate View” from MMB, to Alt + MMB. In either quad view, or a maximized Top, Side, Front ortho, I can still rotate, but having to hit one extra key helps me not do it on accident.
Then again, hopefully the issue doesn’t resurface the new shortcut becomes second nature.

I’m surprised that no one else has a problem with this. Don’t you find yourself accidentally/instinctively rotating the view in one of the orthos?


(Thies Schulz-Holland) #16

“Auto Perspective” doesn’t lock viewport rotation.
This function is again tied to Blender’s definition of “perspective” and “orthographic”: Say, you are in one of the six “fixed” views (top, bottom, left, right, front, back - let’s call them SIDE views, shall we?) and in orthographic mode. And now you rotate the viewport out of the side view into a “free” user view.

With “Auto Perspective” enabled, you will automatically rotate out of the orthographic side view into a perspective user view. With “Auto Perspective” disabled, Blender will stay in the previous viewing mode, so you rotate out of the orthographic side view into an orthographic user view. “Auto Perspective” can be helpful if you e. g. model in side view/orthographic mode to follow schematics or modeling sheets of an object, but want to quickly check if you get the proportions right in user view/perspective mode.

Can’t say that I have problems with accidentally rotating out of the side views. In fact I like that I can.

I e. g. really dislike the way it is in MODO, where you explicity have to hit Ctrl-Space > Perspective every time you want to leave the side views (kind of stopped using MODO with 701, so I’m not sure if this is still the way it works…).

BTW, in quad view with “Lock” enabled you should not be able to rotate the top, front and right ortho sub-viewports…?



(jonsandbox) #17

Hi IkariShinji,

Yeah, I think calling them “side views” is more accurate.

Good call with the Lock Views. I checked that and you’re right; in quad view I can’t rotate out of any of the side views, which is nice.
Doesn’t work when one of the side views is full screen. But hopefully changing the shortcut for Rotate View to Alt + MMB should help.

Some of this may come from my preference for working in the quad view, and “fullscreening” each view only when I need to, vs modeling in only a single viewport, and switching it from side, to top, to user persp, etc as needed. 3ds Max works the same way as Blender, in that you can rotate out of the “fixed” side view into a user view. Always had trouble in Max with that, as well.


(Blender Gorilla) #18

Preferences>Add Ons>Lock View Rotation and then a checkbox will show up in the 3D View>Properties Region(N Key)>View

They must not have had this Add-on in 2015.