Oscurart Tools: Not included in 2.91

@oscurart
Just noticed that Oscurart Tools is no longer included with the 2.91 build (can confirm it was in 2.90.1). Wondering why and if it will reappear at some point. Was a handy add-on.

Daf

Yes, you’re right.
I had some differences with some people from the community.
You can get my addon from my repo :smiley:

1 Like

Thanks!
Is this the repo you are referring to


If so I’m not sure exactly what I need out of all of those files to install the Tools.

I copied it over from the 2.90 install files and it’s good to go.
Thanks!


Download the oscurart tools folder and paste into the addons_contrib. Then enable it from preferences. I don’t recommend install addons from “install”.

1 Like

Perfect - thanks again! :slight_smile:
Daf

Hello,I copied oscurart_tools to addons:

sudo cp -r /home/alex/workspace/Thirdparty/Blender-28-Addons/oscurart_tools/ /usr/share/blender/2.91/scripts/addons

Enabling it in preferences,then using ‘Distribute Objects’ to distribute selected 5 objects,and got an error:

Needs at least two selected objects

And it seems that this error occurred in old version before.

https://blenderartists.org/t/oscurart-tools-update-rig-model-render-setting-more/576702/28

How to fix this issue?Thanks.

1 Like

I got the same Problem. Got an error: “Needs at least two selected objects” even when there are more objects selected.

EDIT:
It still works with version 2.90.1.

Download previous version of Blender here:
Index of /release/Blender2.90/
and then go to Edit -> Preferences -> Addons -> Search for Oscurart Addons. They are still there.

Sorry, I tried to copy the “oscurart_tools” folder into:
C:\Program Files\Blender Foundation\Blender 2.91\2.91\scripts\addons_contrib

I couldn’t find it in add-on preference setting.

Nope, me neither. Tried a bunch of things, but none of that makes any script or the addon itself show up.

You use this link download the zip and just drag the folder “oscurart_tools” in your addons default folder dir (for windows is = C:\Users\UserName\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons)

That’s what I tried as well, I couldn’t see the addon in the menu.

If you only dragged the folder in there it should be on the list

image