Outliner - Layer visibility

I’m having a bit of a problem with the Layer Visibility selection in the outliner panel. It appears to be frozen on layer 3. I have objects on several layers but no matter what layer I click on the contents of the outliner does not change. The problem may have started after I bulk moved all objects on layer 3 to another layer, I’m not sure if that is when it started but that is when I noticed it.

Have I clicked on something accidentally to cause this or is it a glitch and if so, has anyone else ran into it and been able to fix it. I have of course tried saving and reloading the file. I would like to avoid having to append every object into a new file (the problem no longer exists in a new file) as i have a very large number of background images loaded into the file that involved a heck of a lot of tedious aligning.

I tried appending the whole scene into a new file presuming that would import all the background image settings but nothing at all is imported or appended into the new scene, which I’m presuming is also wrong.

Any takers?

Can you post a screenshot of the problem?

Will do in about 20 mins.

You can see that in each image I have selected a different layer,layers 1 and 6 yet the contents of the outliner has not updated.

You don’t show this in your screenshot but do have you anything in the search filter box in the outliner header ?


I don’t, infact I’ve never even used the function.

Attach or post a link to your blend file

Sure thing. Thanks for having a crack at it Richard.

Enable the button as shown on the 3d view header, then select a layer


Yes, that solved it. I must have clicked it by accident while moving through layers. It’s a button I have never used before nor to be honest, probably ever checked what it was for. Thank you Richard for taking the time to resolve this. I will mark the post solved in the hope that it may help someone else someday. Again, big thanks.