Overlays - geometry wireframe shortcut 2.8

Hello guys,
I just discovered this little small thing that I was missing dearly and that is wireframe over solid objects in viewport. In other software (for example 3ds max) you could just click one shortcut (F4) and you could go on/off for that solid wireframe mode in viewport. This function is nothing big but for me it was supra useful and in 2.79 I could only activate it by objects> viewport display> wireframe + alt click on all objects and that was really clunky (later on I was able to solved that with script that was provided to me).

Now in 2.8 there is awsome new button under the overlays section called wireframe and you can simply toggle it off and on which is just amazing! Here goes my question, when I mouse over it, it says that there is a shortcut “O” but in reality that shortcut is taken by proportional editing which is fine but I can’t seem to find wireframe in preferences > input so I could be able to give it my own shortcut.

For now I solved that with quick favorites but is there a way to get it a real shortcut? Answer might be “Hey it is still just a beta so hang on it will be there soon” but still wanna asked has anyone more clue about that?

Thanks for answers cheers T.

2 Likes

In Preferences > Hotkey Editor:

  1. Add a new entry in 3D View (Global)
  2. In the new entry, type wm.context_toggle
  3. Then in ‘Context’ text box type space_data.overlay.show_wireframes
  4. Assign your hotkey
  5. Save
  6. Have a nice weekend
5 Likes

Thank you very much Iceythe it works just perfectly! Also thanks for showing me that you can actually add a new shorcut tab there that I wasn’t aware of! :ok_hand::+1:

And nice rest of weekend aswell!

1 Like

Thanks. I was having problems with it working in 2.91 because I was trying to assign it to the #4. After some testing it seems Shift + Ctrl + w works. It is hard finding a key already not assigned to something and nothing really says what keys area not assigned already.

After I found an easier way to do it.

  1. In 3D Viewport click on the arrow next to Viewport Overlays
  2. Hover over the checkbox for the Outlines and right click
  3. Select Assign Shortcut press a key not already used. I used Ctrl + Shift + W

This seems to add the entry for the shortcut under Window instead of 3D View (Global). Not sure why, but it works.