Oversampling Bug?????


(Fort Max) #1

Okay here’s the scene. [>]

I have made a model of a character that I would like toon shaded. I do the old ‘shadeless’ button trick and everything is working fine BUT there is no way to make it appear to be lit from any light source. So i’ve fashioned my own solution to this problem- use a texture of a black to white gradient applied to the surface using an empty as the texture co-ords, this way allowing me to move the empty as I would a light and still keeping the toon shading. :o :o

Now, my problem showed up when I went to do a good large render. I put oversampling on (I don’t use it for test renders) and when it rendered I had this strange sqaure-ish blocking of the colours. :x As soon as I turned the OS off it went away. :expressionless:

I’ve tried fiddling with all the settings I thought could make this happen but could not get rid of it. Any help or suggestions would be appreciated. :smiley:


(banana_sock) #2

i’ve seen this sort of thing before, mostly when people try to make lightsabers and the blade doesn’t have a nice gradient with OSA on. I’m not sure if there’s a solution, but it is possible to do toonshading with actual lights and get good results. There’s a tute on this page that explains it really well. (reblended, i think)


(funkychild) #3

Have you tried using the unified renderer?