Parenting keep offset not clickable

losing my mind over this. I’m following a tutorial on how to make. sword trail and the guy in the video parents armatures with the “Keep Offset” option.

But that option isn’t available for me and I tried everything to my very limited knowledge to fix it but I can’t figure it out. I’m still very new to blender.

Sadly I cant add 2 images for some reason to this post

Would be awesome someone could help me with this.

This is what it looks like for me

What tutorial? The image shows “keep offset”. Do you mean parent armatures or parent bones? Armatures would be in Object mode, and bones in edit mode. You can do both.

EDIT: I guess, rereading the title, that keep offset is not clickable, didn’t notice that.

A tutorial on YouTube that shows how to make a sword trail and yea I cant click on it

That doesn’t allow me to look at it and see where you might have gone wrong. Maybe a link?

To the video?

That would work.

sure here it is

The part I’m struggling is at 11:50

In the image that you originally posted you are in EDIT mode, you have to be in POSE mode.

EDIT: POSE mode for the bones.

1 Like

I tried it in every mode and it always looks the same
the guy even says you have to be in edit mode

No keep offset option

“Back in object mode I selected the sword and the Armature. I will switch to pose mode and press ctl p to parent the sword to the sword to the sword bone.”
11:33 - 11:40

1 Like

no pose mode this time

The object then the armature.

1 Like

Still no keep offset option

I found out the keep offset only shows in edit mode

Yeah, I’m sorry, I wasn’t looking at that part of the video. Are you sure that you have both bones selected and that they are in the same Armature.

EDIT: It looks like you didn’t use the the wireframe view. So you can’t see through them as well.

OK sorry again, I see in your original image that you have exactly what he has… It looks like the sword is selected then the armature and then the armature is in EDIT mode, but the keep offset option is greyed out. Hm.

Maybe there isn’t an offset to keep?