Particle and Motion Blur options problem. Anyone have the same problem?

I am using Eevee with a looped particle system, in which the particles have emissions.
I also have activated motion blur options.
My project is 400 frames, the first 200 looks


“ok” but there can be seen in some frames the motion blur looks all over the place, instead most of the 200 last frames are all rendered badly.

When I turn off motion blur the render is fixed, but the problem is that I want that motion blur on the video because it makes everything more “real”.

Does anyone have the same issue?

Could you describe the problem in more detail? Blur looks all over the place means that the blur is applied everywhere, even the parts that are not moving? Has the camera animation, and did you use and animate DOF?

And with rendered badly you mean that the whole render is blurry, right?
And what do you want to tell with your screenshot?

Hello and thanks for the reply.

The camera has both depth of field and focal length animation. The DOF is not focused on the particles but on the middle mushroom. The focal length animation has a 1-degree movement for 200 frames.

The blur should be applied to the particles and not to other objects on the screen as the particles are the only ones which are moving at a speed where blur should be applied by blender.

Here are 2 different frames where 1 is rendered correctly and one has a problem, both have Motion Blur enabled.


I have tried to turn off DOF, try different focal lengths, etc etc, but nothing seems to work, the only thing I could fix this problem is by turning off motion blur.

One last thing I have to clarify. The particles are taken from an Alembic file which I have rendered beforehand. The same file is imported 2 times (because copy-pasting it from inside it, linked the animation), and I have instanced an Ico-sphere with emission to this Alembic file.

The particle systems have 600 frames. One starts at -400 frames and the other starts at 0 frames.
My video is 400 frames. With both these particles systems, I could create a perfect loop.
The second particle system which starts at 0 frames seems to have a lot more problems than the first one which starts at -400 and ends up at 200.
But from watching every frame carefully, even the First Particle system which starts at -400 has the same issue but is less visible.

I tried exporting different particle systems to see if that one I exported had problems, tried importing it from 2 different sources etc etc, but everything is fine, the particles behave very well, in the viewport everything is fine. This problem happens only when I render it.

If you want to take a look at the files you will have to do some manual work to call in the alembic files but here is a link to all the files:

Thank you very much.

That is quite a huge Blend file. A lot to investigate.
First I turned of a lot of collections, an attempt to isolate the issue. So All I got enabled for render is Scene and ctrl, Particle Done. In that case, it seems the particles render, I mean no issue with motion blur. And I don’t know what the intention is, but if you mean there is an issue around frame 200 and 300, then I would say it’s an issue with lighting or shader. Not an issue with motion blur.

Its a bit hard to find out what it is, because a) its quite a big project / huge file and a lot going on b) I don’t know what your intention is. At what frame the problem starts and end?.

Maybe it’s an idea for you to isolate things, like what I did here and test.

1 Like

Hey there, thanks for taking your time to check it out.

The problem starts around 200 frames and ends at 400 (so I can make a loop).
I tried to do many tests but ended up not solving the problem as like you said, many things happen at the same time and its a big file.
What I did instead was to turn off motion blur entirely, and do all that later in after effects, where I added a little blur and glow to the particles, and they looked even better.

I will continue to experiment with the particles, and if I find any solution I will update! :raised_hands::grin:

1 Like