Particle Edit is suddenly stuck being Object Mode?

This is only doing this in one file, but uh, it’d be nice to fix it since that file is important (oof!)

You know how when you swap to Particle Edit mode you can, well, edit the particles! And then you can not do object-y things, like moving around an, uh, object!

WELL, for some reason right now, on an object that has not one but FOUR PARTICLE SYSTEMS! if I swap to Particle Edit it still lets me move objects around with G and, in fact, does not let me edit particles.

I do use Hair Tool (I was experimenting with particles to curves) but disabling that addon hasn’t fixed it.

Here’s the blend in question.

Particle Edit mode was in fact a cache mode in 2.79.
You could edit softbody or cloth cache, the way you edit particles.
That aspect of blender was not cleaned up or functionaly restored in 2.80.

That said, there is a cloth object in your file.
You probably edited it. And now, when you try to edit particles, Blender think that you want to edit Cloth cache.
You have to open Options panel under active tool settings.


Change Editing Type from Cloth to Particles to be able to edit Particles.

3 Likes

OH MY GOD THANK YOU SO MUCH what the actual heck blender oh my god.

thank you. so much.

A post thats not from 2013 and actually helped