particle hair animation problem

Hi there.
I’m currently working on a simple animation of grass on a plane.
The problem I have is quite a pain : the seed of the particle distribution seems to change at each frame, making the whole animation a fail. Strangely this problem only happens when I hit render. Animation in the viewport is OK.
I should mention here that the particles emitted are meshes with a simple animated rig (grass blades bending).

any idea why the seed changes?


Have you animated the seed value.
Supply a demo blend file

Nope, no animation on the seed…
I’m preparing the blend file…

here’s a wetransfer linkto the blend file :

I’ve tested several things but can’t find a solution :

  • tried to render without the armatures on the blades, but it does not work either…
  • there’s a seed animation for the render noise. Tried without…nope
    Any help is very appreciated

There is a driver on the seed value of the sampling. It looks like it is changing the seed value of the render. Don’t know if this is it or not. I ran it for a few frames without the driver and using a static seed for sampling and didn’t have an issue.

Thx Stilltrying for taking the time to check.
I’ve tried that too but it doesn’t solve my problem. the distribution of the particles is really erratic between the frames…

The problem is with the hair density texture (tex) you are using a procedural texture for length and density and have the mapping set to generated. I would probably just delete the texture and use vertex groups to control density etc… The mesh is subdivided heavily so it won’t be an issue. The other alternative is to unwrap the hill mesh, and set the mapping to uv in the texture. Either one will stop the insanity.

Other note. Often times you get a smoother deformation by moving the subsurf after, or below, the armature modifer. In this case there’s not a big difference. And at this range you can probably turn subsurf to 1 on the blades and get a big jolt in render times.

You are clamping direct which is unusual and will have a dramatic effect on your lighting. Unless you know exactly what you want, better to just clamp indirect, and change direct back to 0.

Thanx photox, I would never have thought about that mapping issue! you really helped me there!
BTW, the clamping is a mistake obviously, thx for noticing that too!

Yeah it’s a weird one. I recenlty did a quick animation I made of a scene with a floor with a displace modifier using a procedural texture, and was dissapointed when I watched the video as the floor was dancing. It seems like the texture should remain constant (unless it was moving) but, well it doesn’t. I don’t know why that is.

Thanks Photox. Didn’t mean to bump this thread, but that cleared mine up as well. I guess a procedural noise is resetting every time a move is made, which now makes since. This solved mine as well. NO MORE Procedural types on animations LOL.

As far as i’ve noticed, this problem only happens with particle sims. Procedural textures on other onjects are stable.
anyway, thx again photox.