Particle hair - Edit Mode - Only displays active particle system


(Peter18) #1

Hi all,

Just wondering if this is a known issue or not. But in 2.8, when going into particle edit mode, it will only show the current active particle system. it should show all particle systems on that item, allowing you to toggle visibility.

As you can see from the screenshot, the particle system named Hair-Main becomes hidden. I assume this is a bug, or perhaps a known issue. Or I’m just being thick…

is there a work around? (I could use 2.79, yes…but you can’t open 2.8 files in 2.79, so I’d have to append it all, and hope nothing breaks)

Thanks as always :smiley:


(yogyog) #2

Can you even do this in 2.79? I’ve not edited particles in a while, but I’m not sure if you can ever see multiple particle systems while editing them.


(Peter18) #3

Pretty sure you can yes. At-least, in the particle hair video I watched on YT, they could.


(yogyog) #4

Hmmm… then maybe report a bug… see if someone has already first - save you the trouble.


(Peter18) #5

Quick update to this, it did randomly start working for a short amount of time (which confirms it should work) but then stopped again. So, I’m guessing it’s a bug…


(Peter18) #6

Another update. I’ve worked out how to reliably activate the particle systems in edit mode. Basically, if you cycle through them, and on each layer, enable and disable the Children checkbox, it should then stay there when you click on a different particle system. it still disappears sometimes, so you have to do it again, seemingly linked to Undo.