Particle transparency shows as black in cycles

Hi Folk,

I can’t seem to get blender to show transparency for particles. I have created a fade from diffuse to transparency using a method I found and it should make it fade from solid colour to transparent but the transparency shows as black. I have tried a basic transparency to test, which works on a cube but not on the particles. Any ideas? I am reasonably new to blender so be gentle.
Greg


You have to pipe a Transparent shader into the lower mix shader input. It shows as black because the input is empty so it doesn’t know how to handle it.

Hey; I notice in your pic you do not have anything connected to the bottom socket of the ‘mix’ shader. My guess would be that is the problem. You are trying to mix something over a time(age) period & Blender is like ‘what am I mixing ?’ This is just my guess though…

Thanks guys but I’ve tried that, I have even tried just using the transparency set to 100% and it shows black instead of transparent, see the examples below:


How man particles do you have?

It contains 32000 emitted from the vertexes of a circle The particles are from a created circular object. Apparently, cycles won’t display them otherwise.

Hey; I notice in the first pic (post #4) that there is less black at the tops now that you have something connected to the bottom socket. Have you tried a different lamp ? I must admit I’m not that good using ‘Cycles’ as I am a ‘Lux’ user.

I think you might experience a problem with the standart settings for cycles. It could be based on the max Transparency setting because Cycles will stop passing light through the "n"th object that has a partial transparent shader. You can change that setting under your Render Options > Light Paths > Transparency > Max. Set it to a higher number for testing purposes (like 100). If there are less parts that are black you know that you can tweak this setting. If nothing changes…then I was wrong :slight_smile:

2 Likes

this comment saved my life

1 Like

I’ve subscribed to this website just to say that this comment saved my life