Particles emitted from fast-moving objects not interpolated well

I’m slightly embarrassed to be asking this…

I’m making a rocket trail for a commerical animation. The particles are emitted from a plane parented to the rocket mesh. The problem is that they are emitted in bunches every frame, like this :

Whereas in older versions of the particle system, say from 2.45, I get this (with the equivalent settings) :

Now there fortunately isn’t any overriding reason to use 2.49, I can go back to 2.45, but I prefer not to. The particle system does have the nice brownian motion feature, amongst other things.

Much appreciated,



Posting a BLEND can often help in diagnosing these kinds of problems.

I can not reproduce your problem. In my blend file, the particles do not clump up like that.


particles on path.blend (803 KB)

Many thanks. I was parenting the emitter to the path with ctrl+p, normal parent option - it seems that was the cause of the problem. Apparently, using a follow path constraint instead (as in your .blend) does not cause the weird bunching. I wouldn’t have thought to try it that way - thanks !