particles emitter bug?

Hi everyone!

I noticed a very weird thing going on with 2.70 and 2.71. Did not check with previous versions but honestly I never noticed it before.

New scene, delete the cube and add an icosphere. Delete the lowet half, add a particle emitter on it.

Set the emission start end to something like 3-5 and the life to 2-3.

If I both play the animation, or bake the simulation I get the initial “explosion” of particles, but then, some frames after, the particles keep being emitted again. They are just emitted and do not move from the surface.

Doing the same with a cube for example did not give me this problem.

Do you get the same?

Thanks for any help

EDIT: now I am getting the same with any mesh…

I cannot reproduce such an issue here (Linux 64bit, latest head)

How about posting a file that demonstrates the problem instead of expecting us to reproduce it based on a description that includes phrases like “something like” and “some frames later” and other vague things that make it impossible to tell what other important information you’ve left out?

here is the file. This was made on my home computer, while today I had the problem at work. Both win7 64bit.

Hmm… After freeing all bakes the particles behave as expected (viewport render AVI). Not sure what kind of hiccup occured on your machine.

the strange thing is that the same problem occur on different machines… you say you just cleared the bake data and baked again without any change to the settings?

I remember now (was quite late yesterday): There were actually two steps. What I did was…
a) Free all Bakes and
b) set Physics to “No” and immediately back to “Newtonian” again.

After that the particles “behave”.

wow… this looks to fix the problem indeed. btw is quite odd, without knowing this “trick” could be quite frustrating. And is not that I am a newbie to particles, I used them quite a lot, but all of a sudden I had this strange glitch.

Thanks for the help!

Quite frankly: I stumbled across this “fix” just by dumb luck and blindly experimenting…:wink:

yeah I imagined it… that’s why it could have been quite a big problem if you wouldn’t fixed it by “accident” :smiley:

However, I still wonder if I get this only on my computers (because I got it on two different computer) or is a problem that you also get starting a file from scratch…

Just tried it: In fact I get the very same issue like you with a new file.

a) Add cube to scene (I don’t have a cube in my startup file any more…).
b) Add new particle system on that cube.
c) Set Start = 3, End = 5, Lifetime = 2
d) Play.

The particle system only works as expected after turning physics off and on again.

Maybe then I should post it in the bug tracker… what do you think?