Path usage

I’m playing with a script i’ve written for someone.

I have a curve and when I add some objects with follow path constraints it starts them in the a strange place (it uses a number of circles joined together and then an offshoot either end) and does a single loop of a circle (not starting at the end of an offshoot).

However tests on previously created curves and new curves not joined like this one, work fine and as expected.

I’ve tried changing direction, converting to curve / mesh, etc, what else could be wrong with this curve and how do I fix it? :rolleyes:


Make sure the path’s origin and the objects origins are at the same spot.

Technically they are, but only the objects really require to be at the scenes’ origin. But it’s this one curve which is the issue!

Hmm. Did you try to apply the location of the objects?

None worked… (e.g. applied all)


Could the path settings for animation be conflicting with the script?

It set’s them itself, but it’s also the same starting position as the others… (Should be default)

TBH it seems to be just reading the first original circle which I turned off cyclic and ignoring all the rest…

Also tried in 2.57, and using 2.58…

Not to worry, hopefully it’s just an anomaly in the way I formed that particular curve, but…