Phantom Bounding Box

New to Blender, so don’t know anything. I ran into something I couldn’t find using the tutorials, so thought I’d try here.

I was using Box Select to grab a Plane object, rotate it and transform it. Somehow I managed to leave a ‘phantom’ bounding box (as part of the object) in the view. It renders without the box showing up, but I’d like to know how to get rid of it for future reference. Only day-3, so I really don’t know anything.

It doesn’t show up in the Current Scene of the Outliner and I don’t know what I’m looking at in DataBlocks so wasn’t able to find it and delete it.

The included image shows what I’ve got.

Attached: arrow2.blend if you need to decipher DataBlocks.

Thanks for having a look.


arrow2.blend (517 KB)

this happened to me too, why that shortcut key is there ill never know. you just need to go into the Object Properties and under “Display”, uncheck “Bounds” or “Texture Space”.

Thanks Daedalus, unchecking Texture Space fixed it. I don’t know how to mark this [SOLVED] or I’d do it. In any case, thanks for taking a look.