Picture Attached :: How come Character Rigid Type have such a huge gap ? Thanks

Just started out with UPBGE so sorry for questions like these.

If your plane’s collision type is set to say Box, your plane’s Origin point is probably un-centered.

You can easily see collision shapes/lines by turning on Physics Debug in the Proprieties Window:

As you can see, at runtime with physics debugging enabled you may see that collision is being calculated locally from the origin. The mesh is offsetted from the origin so you need to re-center the origin point.

You can reset the origin to the mesh location by doing Origin to Geometry:

Documentation for orgin to geometry: https://docs.blender.org/manual/en/latest/scene_layout/object/origin.html

Thank you.
Thanks to you, I was able to see what the problem was !
Setting the bounds to box is BAD if the origin is at the bottom of the cube REGARDLESS of you having applied rotation/scale !
Setting it to Convex Hull fixed it !

Note to self…ALWAYS USE Convex Hull.

convex hull isnt what id call a solution. box/sphere/etc are cheaper and likely more stable. notice that sphere type uses the radius setting to set size.

just move the origin. the origin is also generally the center of gravity. also, having the scale other than 1,1,1 could cause problems and should be used with care.