Pixie Problems

I have been trying to use the Blender2Pixie.py script but I am gettting the following when I run the script:

Using Python version 2.4

------- script start

/program files/pixie/default//SurfaceShaders/
shaders dir: %PIXIEHOME%\shaders
scene fname : /program files/pixie/PixieTest//GlobalProperties/GlobalProperties

trying to load fname:/program files/pixie/PixieTest//GlobalProperties/GlobalProp
Exporting Frame: 1

trying to load fname:/program files/pixie/PixieTest//ObjectSettings/Lamp.002
couldnt load file

trying to load fname:/program files/pixie/PixieTest//ObjectSettings/Lamp.002
couldnt load file
Exporting: Cube

Then when I try to run the RIB I get:

C:\Program Files\Pixie\PixieTest>rndr pixietest.rib
pixietest.rib (6): Unknown option: "shadow"
C:\Program Files\Pixie\PixieTest>

The resulting image that I get is black. Any help would be appreciated. Thanks.

Hi ! I know that ther’s some problems with paths. Pixie and other renderman compliant renderers don’t like spaces in path like in “program files”.
Try to move your Pixie path to C:\Pixie and set your pixiehome. This should solve some problems…

By the way, are you using Shaderman to create your own shaders ?

bye, Messiah

I did finally get it to work yesterday; like you said the problem was path related.

Do you have much experience with the Blender2Pixie plugin. I’m having trouble getting anything at all to change with the shaders for the different objects. They always seem to have a matte finish no matter what I change in the Blender2Pixie interface.

I tried Shaderman some time ago, but I’ll have to refresh my memory on using that sometime soon.

Actually i don’t know this plug-in (maybe it’s another name) and if you could tell me where to find it… :smiley:

As for shaderman, i’ve got a problem with setting up Pixie renderer. I only get black screen for preview… If you know a solution…

bye, Messiah

I should have said script, not plug-in. Here is the link:


As far as getting shaderman to work, I just downloaded it again and the only thing I had to do to get it to work was to change the paths to get to the Pixie shader compiler and Renderer under the Tools menu and Settings… for the Pixie renderer.

Ok great thx to you :wink: