Pixilated reflection of light emitter


I’m using Cycles.

The reflection of the light emitter object/material is rendering pixilated. I’ve tweaked a lot but still no success.

Am running an eight core cpu and can only put one set of subdivision surface up to 6/max per object, I don’t know if that’s the end all of it.

If the pixilation can be smoothed out that’s what I’m aiming for.


Hi. check set smooth to the spheres.
Subdivision 6 is overkill, 3 should work in most cases.

Cheers, mib


Hi, mib, I’ve tried smoothing before. But there are still jagged edges to the reflection of the object emission material.

The rest of the reflections are smooth, is there anyway the emission object can meet these standards?

I’ve included the set-up suggested.

It appears that if you go over 2 strength with the emitter material it begins to pixilate.

I can’t see the pixellation you’re talking about. The first reflection’s edges are a bit sharp, but that’s a given when antialiasing values over 1.00.

For reference, I only set the spheres’ surface to smooth, and reduced the subdivs to 3.

Ovnun, is that shading: smooth, or another type of smooth? you said surface smooth? if so where can I find it?

The Surface of the material doesn’t have smooth option.

Shading: Smooth.

EDIT: Ah! I downloaded your first file instead of the second. Your second one renders more or less the same as my version.

I just upgraded to Blender 2.77, and it worked the way Ovnuns is. The rendering in cycles anyway is better in 2.77.

Is there anyway to get it any smoother?

where are the anti-alias options/values?

Thanks for the help both.

Hi, there is the old fashion way, render double dimension an scale down in Gimp, PS or so.
Check image in Image viewer.
Check your display driver AA settings.
There are no AA settings in Cycles.

Cheers, mib

You could try blurring it a bit with some post processing. The Glare node blurs pixels above a threshold of brightness. But, without post, I think it can’t be done.

Think about this: You have a pixel at 1.0 brightness, and you want to antialias it against 0.0. You would then generate one or more pixels with intermediate values.
[1.0] > [0.8] > [0.6] > [0.4] > [0.2] > [0.0]
So far, peachy. But then you want to do the same with a 25.0 pixel. You generate the same amount of intermediate pixels, but most of them are above 1.0, and that can’t be shown on screen, so they get truncated to 1.0.
[25.0] > [20.0] > [15.0] > [10.0] > [5.0] > [0.0]

I’ll try some post processing. Thanks again both.