Playing with Landscapes

nature
blender2-80
(Leonard Siebeneicher) #1

I like to get a more in-depth understanding how to achieve large-scale nature scenes in Blender. Keeping it simple.

MTree helped me to create trees for the forest scene. After some fiddling, Particle Instance (on leaf) works with the leafs particle emitter.

I oriented to lolwel21’s feedback to rework the landscape scene.

Leafs are smaller then a fraction of a pixel. Asking myself … is it nescesary to keep leafs that small?

0 Likes

(Leonard Siebeneicher) #2

Basic Trees done with ModularTree addon. Blender 2.80.

Landscaping is like dancing with a freezer. Any wrong step, and Blender freezes in a loop, or GPU exhausted, or memory exhausted.

I keep particles in bounding box, and used child particles to reduce particle count on viewport and keep UI fluid.

Landscape is a dynamic sculpting.
Simple green texture.

Before I started with sculpting I watched timelapses on erosion.
Now, the trees …

There are strange artifacts. They do have polygon shapes. Not sure, what caused them, and how to get rid of them.

0 Likes

(Leonard Siebeneicher) #3

Mh … render artifacts on landscape related to particle children. I used thousands of render particle childs. (Interpolated children mode.)

After I reduced children count and set higher emitter count, artifacts got tamed a bit.

It seems, children mode ‘simple’ works better for large scale forest. Next image is done with ‘simple’ particle children mode.

0 Likes

(lolwel21) #4

Starting to look pretty good!
Are you specifically going for a super-dense forest, or do you think adding a few clearings here and there would look good?
Also, judging by the visual repetition on the close side of the image, it looks like you don’t have random rotation set up for your particles. Is there a reason for this? Adding random rotation really helps get much more visual variety out of a single tree model.

EDIT:
I just realized that a large ratio of child-parent particles will produce a similar effect to disabled rotation, even if rotation is enabled, because all nearby trees will share the same rotation. To remedy this effect, there are a couple options.

  1. Make sure your parent particle density is significantly higher than the radius for child particles (using hair particles with simple child method) so that clusters overlap significantly
  2. Use a higher number of non-hair particles with no children, and using Display mode: Point to accelerate viewport function back to usable frame-rates.

I personally used method 2 for my forest in the MTree thread.

1 Like

(Leonard Siebeneicher) #5

I like to keep dense forests on hair particles. Like an etude, I try to focus on a technical problem. Its difficult to achieve both, variation in the forest and fluid blender.

Child particles do not vary in rotation. And child particle radius (Simple Mode) is limited to 10m. Thats 4 small to medium Trees, unless downscaled.

There might be workaround. I try to make single particle system not too dense, but layer several particle systems. I hope I could resolve repetive-children problem and keep blender fluid.

But I like to try your 2nd solution, too.

Happy blending.

1 Like

(Leonard Siebeneicher) #6

Its a test … animated landscape, trees moving to wind. At least, they should do.

I try to render a 250 frame animation. Used Blender 2.8

Result:
Each frame consumes a bit more memory. after around 100 frames, 16G memory consumed. On around frame 120 stunning 32G memory were consumed. It was not possible to render all 250 frames in one render session without freezing my machine.

Killing blender process was a meditation session.

Now, remaining rendered frames glued into a video file. Video shows, that whole physics stopped working at some frame position.
Aaaah … grmpf … Donnerwetter! :cow:

0 Likes

(Leonard Siebeneicher) #7

Another try.

Increasing memory consumption was caused by ‘Persistent Images’ setting. Without, memory consumption did not raise during frames rendering.

Still, little problem nibbled on the forest ani. You’ll see.

0 Likes

(lolwel21) #8

Your trees! They’re swiveling! (I think you’re using hair physics.)
Try just animating the tree mesh itself, and leaving the particles alone.
If you’re using random rotation, that saves you from the repeating tree artifacts, letting you use fewer tree models and saving RAM.
However, it also means you will only be able to model turbulent (non-directional) wind.
This is something Gooseberry had a huge problem with, and they never found a solution they were entirely satisfied with.

One potential idea is to do the wind animation procedurally with shader-based vector displacement (2.8 only). Not sure how good that’ll look, though.

1 Like

(Leonard Siebeneicher) #9

Huh … yes. The trees roll. They spin around their own axis. I liked to understand if there is a way to use Blender Force Fields together with a particle forest.

It will be difficult to use animated Displacement with the forest. How to balance all the leafs to fit the tree with its branches? How the UV’s of maany twigs should be set to match the branches? I fear, this would be a tough one.

I hope, animation nodes will open new ways to animate a forest with force fields. For now, I will try animated tree mesh method.

0 Likes