Please Help. Brand new to modeling.

I’m new to modeling. I always try to make tracks or pipes. I can’t seem it get it. Here is a image of what’s happening when I import into unity3D Engine.

I am making a circle and a path for the pipe and just beveling the objects. My friend told me to flip the normals by pressing w in edit mode. I does not show up anywhere. I have no clue whats going on. Please help. Thanks!

Did you use Object/Apply/Rotation and Scale? That sets the Transform data rotation to 0 and scale to 1. Strange things can happen if this isn’t done, in addition to not making sure the normals are all set properly. This may make it easier for Unity?

Neither do we. That small image is the only thing to base the guesses on.

By the looks of it the camera is looking inside the pipe and backface culling makes the faces disappear when camera looks at them from the backside. If the purpose is to have the camera inside the pipe then the faces should point inside and have to flip the normals that way. Otherwise they’re fine pointing out but have to figure out how to not show backface culling in Unity or give the model walls some thickness.

You probably won’t need two objects to make a pipe. A curve can be turned into a pipe by increasing the bevel value and enabling full fill. Also the resolution can be changed along and around.

If you’re confused as to why the inside of the pipe appears transparent then it’s because the game-engine is using Backface-Culling which essentially hides faces that have a single normal direction. That’s why front facing faces are still visible further down the pipe when looking through.

If you flip the normals then this is reversed and you’ll not see the pipe at all. To fix it you either have to disable Backface-Culling or make the object double-sided, whether that’s through the software or by physically duplicating the mesh with inverted normals.

Hope this helpes.