Please help, trouble with armature

I just read and learned about armatures and animation.
I can attach a simple armature to a mesh and move things.

  1. create a box
  2. create an armature
  3. parent the box to the armarture by selecting the box, then the armature and pressing crtl-p
  4. choose from closest bones (or someting)
  5. a vertice group gets assigned to the vertices and by moving the armature, these vertices move deforming the box.

This works great. So, I thought I would try this on my WIP female character as a test, but it does not work.
When I try to apply the same method (as found in the online manual) to my female model, it does not work. I can move the armature, but nothing happens.

Here’s a screenshot (only a test to show you):


did you select the arm or the body first?(when making parents)

ok then click body, hit shift, click armature(s)
then hit control+p, click use armature and do according to closest bones…

do that if you didn’t…i do this method all the time…and it works every time…

Yes, I first selected the body and then the armature… the body was dark pink and the armature light pink as describe in the manual.
If I use the same method on a simple object, then it works…
Damn, I can’t seem to animate my model, oh no…

Make sure that your 2 halves of the mesh are joined (you can split them again later if you want)

Then add an Armature with bones for each part of the mesh, leg bone for each leg, arm bones for each arm etc (add bones with armature in edit mode so it all stays one armature) even if you don’t intend to use the leg bones.

If you only add an arm bone and use “From Nearest Bone” then the legs, head, feet… everything in the mesh will be parented to that bone.

If you want me to look at your file send it to ([email protected])


I don’t think it would make a difference if the mesh was in two halves. I’ve rigged separated meshes that were made with alt-d before.

Could it be that you have accidentally set the weight of the vertex group to zero? If you go into weight paint mode, the arm should be coloured red.

I can’t think of anything else that could be wrong off the top of my head. I know that the delay deform option waits until you finish moving the bone before deforming but it would actually deform it eventually.

If you can post the file like Fligh % said, that would help but I know if you’ve worked on it for a long time that might not be something you want to do.

are you using the cvs? make sure you have the armature set to ‘deform’ if so.

Ok, i tried some things, but it is not working.

Here’s a blend file that holds a piece of the arm with armatures. Hope this can help you guys to trace my mistake…:

(remember it is only a test, but this blend file has the same problem.
The complete wip of this model is at:

If you click the padlock next to the layers buttons, the rigging works.

For some reason, you have a mesh object there that I can’t delete. At least not very easily. The sphere and plane delete OK but there is another item called mesh that behaves very oddly.

Maybe you added it via Python? I actually managed to delete it but I forgot what I did.

Edit: you have to have layer 11 turned on. Then it lets you delete it.

If you open the outliner, you will see that it is there. The outliner is one of the most useful panels Blender has. I would keep it open at all times.

Anyway, I hope you can get this baby shakin’ her a** now ;).

PS Your camera is also set kinda oddly on layer 11 - it’s set as orthographic and you have the bones to rotate around the 3D cursor where they ought to be round the median. You probably know that though but I thought I’d mention it just in case.

You have everything locked on layers 10 to 20. Click the lock in the present view to get there then Unclick the lock, select Layer1 only and lock it again. Now your armature will work.
LOL osxrules… snap.


A big thank you to all! It now works fine:-) So I must have locked things by accident… I just got curious about animation and read the manual…so after that I figured why not try it already as a test, and it did not work…I was in panic that all my work was for nothing;-) but again, thank you guys for helping me out here!!!

I hope to rig her in the future when I learn how to do it in a good way, because armature look easy, but the deformations do not…

edit and I will locate the strange object using the outline , thanks!