Pose Library not saving certain bones

Hello again. I’m posting this again with some updates because no one can seem to help me get anywhere.

I have a problem with my pose library, it does not save the positions of certain bones in my rig.
For example, if I create a new pose, move my rig into another pose and create a second pose, then switch back to the first, it will only change back the positions of some bones. So this means things like the left elbow end up in positions they shouldn’t be.

I have checked all the bones that do not get saved and I can see no common thread between them, it seems random. They don’t have any special names or prefixes besides a simple ‘.L’ or ‘.R’.

I have been asking this question in every place I can on the internet for about a month now, and no one seems to be getting anywhere. I have even submitted a bug report to blender directly, with no response.

To rule it out right from the get-go, I select all the bones when creating a new pose. Pose libraries have nothing to do with keying sets, so those are out too.

I would post a file, but I am unable to since I am a ‘new user’.

1 Like

I’ve occasionally noticed a similar behavior (as you’ve described) on one character I’m rigging currently.

I didn’t have time to test thoroughly, but the behavior seemed indeed nonsensical—it really sounded like a bug. I’m not very familiar with the Library system nor the Pose Library, so I wasn’t sure if I did miss some step in my process. However, in early April this year I have successfully tried out the feature on the same character and it worked smoothly without any weird behavior; so I don’t understand what’s going on.

Maybe this (buggy?) behavior is happening on the interaction with certain features of the model I have only added more recently; I suspect it could be something related to Bone Constraints, Modifiers.

I’ll be checking again to see if I find anything new; thanks for sharing this issue and for reporting the behavior.

1 Like

So, I think it’s not a bug after all.

What you must be sure of, is that all your Bones of a current pose you’re willing to store in the Pose Library are Selected when you press the button Create Pose Asset on the N-Panel.
Having all the Bones Selected is not necessary to recall a stored pose; only to store it.

Please check this in your file and see if all is working as expected.

PS: I have lots of Bones on many different Bone Layers, but my test only required me to Select All Bones from a single Bone Layer —the first one, which is where I keep most “Controller” Bones. So, it’s not exactly that ALL the bones need to be Selected when storing a pose; just all of those that are controlling the pose on higher hierarchies, like in my case, such “Controller” Bones. Still, I have other minor “controller” Bones on another Bone Layer, but I wasn’t using any of these to make the current tests. If I required to pose them too, to simplify, I’d probably have to be Select All the Bones from those 2 Bone Layers to properly store a pose.

1 Like

Hey thanks for responding!

The ‘Select all bones’ strategy is always the first thing that’s suggested to me. Unfortunately I have tried and tried and double checked and everything else, and unfortunately it just isn’t any different.

I did decide to go and check the pose library in the action editor itself, and I discovered a few things. Poses are stored as keyframes, and as expected keyframes for the effected bones weren’t there.
If I go and keyframe poses manually, and then select them from the pose library, the pose responds correctly even for the effected bones. So I can confirm the root cause of the problem, is that the ‘create new pose’ action does not create keyframes.

Regarding bone layers, I only have one, so that doesn’t seem to be the issue in my case.

1 Like

Welcome and nice findings.

I do not have a production practice on the Action Editor yet; but I will check that finding of yours. I had no idea Pose Library would generated posed Bones’ Key Frames on the Action Editor… but actually this makes a LOT of sense —otherwise ¿from where exactly Blender would retrieve the Poses’ data?

But something is still missing. ¿Why on my model, which was behaving bad like yours, when I’ve started using the method I’ve described, it seemed to fix all my previous issues, and then you still have the issues on your file?
There must be another factor (besides the Bones’ Selection method), that would be prohibiting the posed Bones to be turned into Key Frames on the Action Editor.

Because this seems to be a Key Frame related issue, and because I’m not 3D Animating yet (I’m just Rigging) and thus I’m only using the Timeline just for very basic Physics test (no Key Frames involved there; the Timeline is always “blank” on my file). ¿Was this the same situation of yours when you were trying to store those poses?

Meanwhile, I’ll make more tests here. Cya.

1 Like

Hi, again.

¿Did you make any new findings on the issue?

In the topic (of the link below), which doesn’t mention Pose Library at all, it brings 3 propositions to deal with certain issues users were having with non-saving Key Frames on the Timeline. I don’t know anything about “Keying Set” yet, but it might be limiting the saving of Key Frames perhaps even to the Action Editor (regarding Pose Library use); I’ve just found my file had (as presented in the topic) a non-blank Active Keying Set (in “Keying” dropdown menu, on the Timeline) and also an item in Keying Sets Panel (in Scene Properties Tab, on the Properties Editor); when I removed them both, I was clean to use Key Frames again and the Pose Library was still operating and I’ve check it was indeed saving stuff on the Action Editor as well.

As I was attempting to test insertion of Key Frames, I noticed I was having an alert message that was preventing me to insert Key Frames on the Timeline…and that lead me to that topic. Because I apparently had the same problem as yours and had this Keying Set issues, maybe you should also check that. Good luck.


Hey, I’m back.

Thanks for digging up that old thread for me, and your continued help, but unfortunately it just isn’t working.

I have zero keying sets, so that doesn’t seem to be the issue. However, it leads me to a new theory.

When keyframing manually in the action editor for animation or whatever, blender will always ask for a keying set if one isn’t set. In the pose library though, it doesn’t. This makes me think that Blender maybe defaults to an internal keying set whenever you create a new pose. And for some reason, some of my bones are being excluded.

Unfortunately I can’t offer much more than that, but I will make the .blend file available as soon as I am able to.

1 Like

You’re welcome.

This topic is highly relevant I believe.

I’ve been having some basic notions of Keying and this single tutorial covers many features that might be responsible for certain Keyframing issues:

So for example, if you’re using Auto-Keying, there is a popup menu next to it, with special settings to consider whenever using Auto-Keying.
Also, your theory may suggest you’re facing a more ‘global’ issue on Keyframes, so maybe should be seen in Preferences > Animation > Keyframes, there are 5 checkboxes (3 of them are somehow covered in that same video). Note: on my setup I’ve just got Auto-Keyframing: Show Warning checked. (I believe the warnings you’re receiving on Action Editor happen because you have that checked also, ALONG with Auto-Keying; but it might be that Create Pose Asset button by-passes that security/warning step; not sure).

If you are using Drivers on Bones, be careful because Bones with Weight Paint Bones I’ve found out can have undesired results if they are driven by something else.
Finally, I’d check for every single Bone on my Armature, if it doesn’t have any wrongly placed Driver/Lock/Keyframe on its settings on the Properties Editor (including Bone Properties Tab, Bone Constraint Properties Tab… and perhaps more; who knows); in the case of the Locks, something about it is covered also in that video; but I hardly believe it would be the culprit.

I hope you’ll be able to uncover the issue; it would be terrible if it were a bug, especially because we don’t know what would be triggering its behavior. Cya!