Keying set failed to insert any keyframes blender 2.9

was animating along just fine when I began to get “keying set failed to insert any keyframes” error. What did I accidentally do to create this error and how do I correct it?

Incidentally, this error only happens with a bone that is rotated. No channels are locked and I’ve been using the blue button that inserts keyframes. Even still, manually adding a keyframe (I button) doesn’t work either)

You probably accidentally told Blender to use a keying set.

Look on your timeline view. There’s a dropdown labelled “Keying”. Click on it. Is there something in the “Active Keying Set” field? Then click the X next to that field.

2 Likes

but that’s the strange part. I check the drop-down under “Keying” & the Active Keying Set field is blank. I’m stumped.

Hello @Drew99 did you ever find an answer to this, I’m on 2.92 and have come across the same scenario. All of the solutions I’ve found are about channels either being locked (not for me) or having a keying set active (not here either).

I have tried actually using a keying set but that still shows the same error just without a menu choice.

I mostly use Auto Keying, it’s already set for Add and Replace and if I make a minor tweak this sets a keyframe fine, but I’m wanting to insert manual keyframes in some places to fix that displayed position so this is not ideal.

I’ve also seen this message when all keyframed channels had f-curve modifiers on them that completely overrode any keyframed values-- when I saw it, it was an expanded polynomial generator, with “additive” disabled.

It would not surprise me if there were other situations where, due to your precise setup, Blender recognized that keyframes wouldn’t matter, and so wouldn’t let you make any. (I don’t think I agree with that philosophy, but whatever.)

If you wanted more help with some particular situation, it would probably require making the .blend file available for peeps to troubleshoot.

I have eventually found the error, it’s this tick box

which must be set by default or somehow accidentally as I don’t recall ever setting it myself.
Once I had the ‘Only insert needed’ text, I found there are a number of bug reports open for this behavior since Blender 2.8.

1 Like

Hello, I encountered the same problem, and the solution is simple.
Delete any value here
tyte

I racked my brain to understand why this happens. And the problem is I need to select all the bones and add LocRot keyframes tens of times throughout the scene. My only workaround right now is that I select all the bones, and with the auto keying enabled, I move/ rotate them ever so slightly holding down the Shift key. Just enough to create a keyframe, without a real visual effect on the armature.