Possible error 2.71 - wrong render result on overlying objects with transparent mat.

I create a simple scene with overlying spheres. Each sphere has #000000 transparent material mixed with grey diffuse. No matter how I set factor on mix shader (even if it should be completely transparent), there are pitch black “things” in places, where spheres are overlapping. Why is that?

Blender 2.71, cycles GPU. Effect persists no matter how I change light, bounces etc.
untitled.blend (497 KB)

The black areas are where the ray transmission stops.

You want the rays to be transmitted through more ‘layers’ of transparency, you need to allow for it in the light paths settings. I don’t know how many objects you have layered, but try increasing transparency and bounces to 20 or 25, though it may need more.

You’re right, 20-21 works. However, it doesn’t suit me, becouse it longers render time and I tried to find a way for some simple, “volumetric” smoke for cycles GPU.