Possible video import bug?

I’m having some trouble with importing video into the compositor in Blender 2.45. I’ve tried many different types of video, and in 2.45, it’s like the image is squished vertically and repeated 4 times on the left. The attachments below show a sample with the .dv file from the “What the Heck Was That” compositing contest. It’s perfect with 2.44, and corrupted with 2.45. It’s the same blend file, and it does not matter if I import into a fresh scene. Oh, and both instances of blender are linux-x64. 2.44 is from the website, 2.45 was compiled from source (i use gentoo, so the package system built it for me).

Any thoughts? Could this be either a blender bug or an ffmpeg bug?

(the 2.45 build was built with ffmpeg-20079999-r2)



No ideas?

(my threads always seem to go unanswered…)

Have you tried other file formats I have never used or heard of .dv?
What if you just use an AVI, PNG sequence or Quicktime?

Maybe you built the 2.45 wrong? You are saying the “official” 2.44 works, but the one you built does not.

dv is usually the format that digital video cameras record to.

I’ve tried all sorts of other formats, avi, xvid, h264, mp4…

If I load a sequence of frames, it works fine. It’s just with video files. I’m going to look at ffmpeg versions…

I can’t tell you much about Linux since I have OS X, but I also have serious problems with the sequencer (NLE) and the Compositing Nodes since 2.44 when using e.g. a .mov video file: blender just crashes… It still all works under 2.43 but in 2.44 and 2.45 I can only use a series of images (just like you) without problems (or as in my case the instant crash).

So it seems there are problems with anything connected to video in blender since 2.44… Since FFMpeg support was only just added in the OS X built with 2.45 I tend to think that the problem has to do with FFMpeg, it seems to be quite buggy… (Also a combined video/sound export only works with the MPEG-2 preset in the current OS X (10.3.9) built for me, all other combinations crash blender or don’t do anything.)

I reported that bug and recently also mentioned it in the other blender forum, I guess the developers know about this, hopefully it can be fixed soon…!

I have observed that version 2.44 and 2.45 have become unstable as well.
Some days it crashes quite a bit then others it is fine so I can not pinpoint what is causing the crashes and most of the time I can not reproduce them either.

Wow, that is bad news! I am having tremendous difficulty with image sequences -


If video input is buggy, and image sequence input is buggy, than the compositor is pretty much wholly unreliable.

My problem is just on the builds i’ve done through gentoo. With the amd64 build of 2.45 on the website, video importing is perfect. So, I just need to figure out what the difference is.

But, I do think we’re all looking at different angles of some deep-seated bug with video handling.

If you think that the problem you have in fact really has to to do with the one I have it might be an idea to post some more details as a comment to the bug I reported - as you can see I yesterday also commented myself once more and linked to this forum thread!

@ Jeremy Ray: TaoTeCheese and me only seem to have a problem when using the Compositing Nodes or the NLE in connection with a video file (like .mov or .avi), but not when using the same setup with a series of images. It looks like your problem is also with a series of images, so maybe this is not quite the same bug (?), but as has been said there seems to be a problem with the way video is being handled in the more recent blender builds… (Stupid test, but might be worth doing: have you tried the opposite, using a video file instead of a series of images…? I just saw: I think you have and it seemed to help…? > If so: important info for a bug report I would say!).

Another workaround for you and others, if this makes sense for your workflow: try using either blender 2.43 (or earlier) when working with video (or a series of images as in your case) in the Compositing Nodes or the NLE - this still works for me, although the workflow gets more complex and this should obviously only be a temporary workaround until this bug can be fixed… (I’m not a coder, so don’t ask me why this is happening!)

indiworks - It’s also possible that you and TaoTeCheese haven’t hit the video sequence but yet. I’ve got many image sequences, with alpha, that work just the way they should.

Converting the corrupted image sequences to video did work for me - but maybe I haven’t hit your bug yet? Or maybe it isn’t in 2.45.

2.43 is an option.

I have the problem solved by using the prebuild version from then blender website


Right - that does solve the problem, but I’d like to find out what the difference is between the prebuilt and the gentoo version. Anyone know what version of ffmpeg the prebuilt version was made with?

I have this issue as well, this needs to be fixed. Observed PPC Mac running Leopard and Blender 2.45.

Does anyone know if a bug report exists on this or is in the works for a fix? This seems to be a really bad bug.

For my own, I have problems when exporting videos with Blender 2.45. I use generally the Avi Jpeg format (Motion JPEG), and since Blender 2.45 when I import a video in an other video editor (Magix Video Deluxe 2007 Plus), the image becomes fully black after some seconds.
If I convert the file into VirtualDub (in uncompressed video,or even using the same format MJPG), VirtualDub repairs the file, and it is fully readable in my video editor (Magix).
There is something wrong in the export code, or in the MJPG codec.
Exporting in sequence of image is OK, but it neads a lot of memory for long sequences !
Weird thing !

Good news for gentoo users! This has been fixed. More here: