Prevent Mesh from being selected?

I noticed some rigs I have downloaded somehow prevent me from selecting the Geometry, and only lets me select the Controls. How can I implement this to make it easier to always select the control?

thanks in advance!

thanks Stan, I am familiar with the basics of the Outliner…I should have been more specific.
For example there is this rig by dFinitly on Blend swap. I actually posted this blend file already on another thread. But I cannot select his mesh AT ALL… Anyone know how he did this? (I also posted a question to him on Blendswap directly and will post answers if I get any)

see attached for Mecha animation file with a seemingly unselectable mesh!


mechaborg_002 by dFINITLY DESIGN.blend (1.52 MB)

Meshes are actually being selected when you right-click on them as usual. What is going on with that file is that Outline Selected has been turned off in the viewport Display itself (N-KEY). This gives the impression that you have not selected anything.

Holy crap, thanks Atom!