Preventing texture stretching

Hi folks,

I have a giant 7 sided cube with inverted normals. I’m using it as my “world” as it takes place within a building. I applied a texture to the floor and it renders as stretch despite being set to repeat. I also tried changing the default x, y values of repeat from 1 to 512 but visually there is no difference. Please see attached screenshots. How do I prevent the stretching/blurring and instead get it to repeat?



I think that under “Mapping” (below “Image Mapping”) you need to set coordinates to generated instead of UV. You also might want to play around with the size settings, also under “Mapping”.

Tried. No luck unfortunately. Size is set to 1 for x, y, and z. Also tried 100, but same result.

This is driving me bananas.

Did you figure it out yet? What happens if you change the X and Y values for repeat in the “Image Mapping” section (when the coordinates are set to generated instead of UV)?