preview cycles ?

how come the preview does not show same thing then what the render is

preview looks very nice but render is rotten or is it the opposite!

thanks for any feedback

It’s a matter of scale. I noticed it too. You just can’t trust the preview to check the size of a texture or the depth of a bump map.

It would be nice if the objects used in the preview were scaled to match the global size of the object from which the material comes. Do you have a dev in your pocket? :wink:

it should be !

problem is
it is per material not object!

might do a bug report on this!


Well, lighting is also clearly a factor in the example image. The preview scene has a kind of “room” and multiple highlights to reflect.

The settings that are built into the preview render would also explain why you have real dark areas in that version, because I believe the number of diffuse bounces is only set to 1. (One reason why it would be nice to have an option to connect the user settings with the preview scene).

not really i got bounce 3 and 8

should it be change for higher values ?

but mat preview is for mat alone i guess
and cannot show real dim function of object
but it would be nice!

a small object preview would be nice


I believe I’ve read in the commit logs that the preview settings are currently hardcoded and independent of the general scene settings. So just because the general scene has eight bounces does not mean it will be the same in the preview.

Also, turning it into a full object preview would be a sizable project and would be akin to creating a specialized mini-viewport widget that can be embedded into a panel, so as of now it just works a lot like BI’s preview widget.

still on CPU till i get a new PC

but is there a way like opening a small window in a corner and render one object fast
like just set object and it renders it in small window
or need a special script to do that !


You can do that actually, just open a small window, set it to show the 3D view, isolate the object using the ‘/’ key, and set the view mode to ‘rendered’.

Don’t forget to save the new layout in the user preferences if you want to keep it when starting a new scene. Otherwise you’ll need to redo it every time.

tried it and it doe snot show the right bumps on selected object
also only light useable is the world light!


You might want to make sure that the lights are also selected when pressing the ‘/’ key.

To select them quickly you can go to select > select all by type > lamp which you might need to do before selecting the object.