Principled Baker - Bake PBR textures with a few clicks (for 2.80 and 2.79)

I tried starting blender from VSC with the Blender Dev extension but got the same result.
Well, I’ll be checking the github repo in the next days. Thank you for looking at this and for your awesome work!

Thank you!
Nice… so I’m in the right place! :slight_smile:
Now just a simple question. How to use it?
Is there a tutorial or documentation to follow?
If my object to bake is inside a scene with other many objects how could I say to the addon to bake that object (or objects)

Thanks in advance

Not entirely unusable, don’t know why but in the especified folder the textures are black, but in the blender folder (the one with the executable) the textures are saved correctly :smile:

There is no documentation right now.

Only selected objects are taken in consideration. Just select it.
Combined is for objects that share UV maps.
Single/Batch bakes every object separately.


That’s a stupid bug with relative vs absolute paths. Will be fixed soon.

1 Like

Hi. Is PrincipledBaker automatically setting the tile size to the texure resolution of the bake.
There is a big big speed up.
Did it wrong for a long time.

Probably a stupid question (I’m quite sure it is) :smile: : is this addon baking just principled shader?
If I have a principled and a transparent as inputs of a mix shader, will it be baked?

update 0.3.4

  • fixed: blender dir as absolute path

The add-on makes no changes under Render > Performance. If certain settings gives better performance, feel free to set up what you like. I have the Auto Tile Size add-on active. Works fine for me.


It should. But it doesn’t. That must be a bug. (edit: should be fixed by now)

update 0.3.5

  • fixed: Alpha autodetection
  • fixed: wrong Color with Alpha mix

It does work now! Thank you very much for this awesome addon.
Question, how can I bake AO and Color if there is no AO input in Principled? I tried mixing the AO node to the Color, this bakes AO Correctly but no Color.


Then I tried with the AO Node disconnected, this bakes Color correctly but no AO.

Thank you!

That’s a bug. Thanks for reporting!

1 Like