Principled hair shader disappeared in 2.79

This morning I tried to use principled hair shader. After I finished doing material, I checked how it looks like in preview render and everything worked fine. Then I sent it to render farm, but when I downloaded result picture I saw that all hair is just black. I opened .blend on my PC to check if I plugged shader output and surprisely instead of principled hair I saw “unidentified” node. I tried it in new blank project, but shader didn’t show up there either.
What is this? It’s not just my problem, render farm uses independent machines with official Blender versions

Render farm uses 2.79b and principled hair shader is in 2.79 daily builds.

But I had it this morning in my blender (otherwise, how could I create material?) and now it just disappeared

Maybe check if experimental features are enabled. But I just think you launched normal 2.79 version.

1 Like

I’ll try, but I’m not sure if experimental feature have ever been enabled

Principled Hair shader didn’t exist in the official release of 2.79.

Ok, It appeared again. Strange

Nope, it’s exist in 2.79

Only in daily builds.

1 Like

Well, I found out that it’s some kind of bug. If I open project with hair material, do something in node editor, then reopen Blender, shader disappears. And appears again after few hours

That’s black magic stuff, computers don’t do things like this.

Computers do many strange things