Principled Shader shows black ring

I found something weird happening when i was testing out the principled shader, a black ring appeared from no where, is this a bug or something wrong with what i did,
Btw, the sphere is an icosphere, i tried it with UV sphere, same result,

Moved from “General Forums > Blender and CG Discussions” to “Support > Materials and Textures.”

Are you positive that the black pixels aren’t in your source image?

This is a ray being “trapped” between two mirror surfaces. It bounces back and forth until the maximum amount of glossy bounces is reached. After that the ray is terminated and - if it hasn’t found a light source by then - turns out black.

Just increase the number of glossy bounces (Render > Light Paths) to 12 or 16 to give the rays a chance to “escape” before they reach the maximum number of bounces.

It worked perfectly in the first case, although shpoting up that many bounces would cost me alot of render time, and the problem presented itself when its at a steep angle, like here,


I stepped up the bounces and it worked in the previous scenario, but when i tilted it at the extreme angles it came again,[ATTACH=CONFIG]521913[/ATTACH]

It workes in the first scenario by stepping up the bounces, but the render time suffered, and theb at this angle it reappeared,[ATTACH=CONFIG]521914[/ATTACH]

is the eye an image with some black iris ?
if there is no light coming from the eye intensity of reflection will be very small and rendered as black reflection

happy bl

I tried, but it shows up here too, when the angle is sharp,[ATTACH=CONFIG]521920[/ATTACH]

That second issue of yours has nothing to do with the glossy bounces.
That’s an artefact from using smooth shading on a low poly object…

Top: Default cube + Bevel modifier + smooth shading + AutoSmooth,
Bottom: Same as above + Subsurf modifier (level 2)

Wow, that works, thanks!