Problem importing .mdd from Marvelous Designer

I am trying to import an animation originally made in Marvelous Designer 3 (free trial version.) I am importing the base object as an .obj (the only non-animation format MD exports in), and then using the Mesh Cache modifier to bring in the .mdd with the animation data. When I do this, the vertex count is correct (no error in the mesh cache modifier) but the object becomes badly deformed. The vertices seem to have been shot in random directions. The only other time I have seen deforms like this is when you apply an armature as a shapekey but with a subsurf modifier above it in the modifier stack.

I know that Marvelous Designer uses different orientation axis (Y is up instead of Z), so I first thought it was a problem with those. But I have tried using the options in the Mesh Cache modifer to change the angles, and also in the MD export options. Nothing seems to work.

I do not think it is an issue with MD’s export, because if I export the animation as an .obj sequence, when I open those in Blender, they seem just fine. I believe there are scripts that can turn an .obj sequence into a mesh cache, or at least shapekeys on an object, but I’d rather not go through the extra steps of doing all that when the .mdd should work.

Does anyone have experience with this issue, or know if there is some hidden thing I have to do to make it work?

You might want to try to match the orientation of Marvelous when you import that first OBJ file. I don’t have Marvelous so I can’t test. It the problem .MDD file small enough to attach here in a ZIP file?

Here is the base .obj and the .mdd. I had to use dropbox as the attachments failed to upload here despite being under the max size.

The .obj importer does have options for changing the orientation, so that could be messing things up. I have tried importing it to what should be the same angle it is in Marvelous Designer, but that hasn’t worked either.

When importing the OBJ into Blender, did you check “keep vertex order” in the importer options? This looks suspiciously like a vertex order issue to me…

Just as I thought. This works: Import your OBJ into Blender with “Keep Vertex Order” selected in the importer options. Body and dress will now come in as one mesh. Tab into Edit mode, make sure nothing is selected, move your mouse over the dress and hit L (to select linked vertices - this will select the entire dress) and then P to turn the dress into its own object. Tab out of Edit mode.

Now add a Mesh Cache modifier to the dress mesh and point that to the MDD file. Adapt the axis settings of the Mesh Cache modifier accordingly to have the dress “standing” upright. Et voilà: The dress is now swaying in the breeze!


Yes, that works! Thank you IkariShinji-kun, keep piloting those robots!

Now, I’m not entirely sure WHY this works though. Why is keep vert order and then separating the object different from Split by Object?

Well, I can only guess from the naming conventions: If there are two options,
a) Split by Object etc. and
b) Keep Vertex Order,
the argumentum e contrario would indicate that in option a) the vertex order is not maintained. Vertex order refers to the internal geometry database: Every vertex has an individual indenture number. And that’s exactly how the MDD works: “Move vertex #34563 by 0.3 units along the x-axis…”. If that numbers’ index gets spoiled, you will end with that ghastly mesh mess.

I assume that when deleting vertices manually or splitting them from another object in Edit mode, the remaining vertices keep their indenture numbers.

Don’t know Marvelous Designer, but can you export only the dress without the body in it from there? That would save the trouble of separating those meshes in Blender again and would also prevent that the body mesh also gets triangulated in the process.

1 Like

This seems to explain some of it:

So you seem to be right about the indenture numbers. I did not realize vertices were numbered like that. I thought it was “Move vertex at position x,y,z by .03 units along x-axis” not what you said.

It looks like I can simply delete the body before exporting the clothing, so I’ll try that next time and see if it makes a difference. Separating the clothing from the body is only a few extra clicks, so it’s not a huge deal. I’m not going to be using the exported body anyway. I’ll be making a body in Blender, animating it, bringing that into MD, adding the clothing, making the clothing animation, then exporting back to Blender. Now that this is sorted out, I can try the next step of bringing animation into MD. Hopefully that doesn’t have as big an issue!

at: @IkariShinji

Body and dress will now come in as one mesh.

Everything works fine for me except that little point… I just get the dress imported in Blender and no body comes with it. Do you know why that is ?
Maybe it’s just due to the versions : I have MD 4 version 2.1.85 and Blender 2.73a
But if someone can tell me how to get the body with the dress it would be super cool because I’m using one of the preset animations of MD so the dress is moving as well as the body and I need both animations. ^^
Thx in advance. :slight_smile:

This posted comment threat was a life saver for me today even after 7 years on the last reply as PC2 import was driving me crazy. Simulation exchange formats seem to be made for providing a major headache (e.g. Alembic from MD is now stable and fine, but does not export textures and materials). Some flipping for the axis in the modifier did the trick to make this work in the end.

1 Like