Problem importing .OBJ files

Hi All,
I have been using Blender to render .obj files exported from Sketchup. Using an older version of blender it works fine with all the individual objects kept as separate entities. When I use 2.8 latest all entities become one. This makes it near impossible to edit within blender.
Any ideas how to solve this? I’m sure a lot of you would say don’t use sketchup, But as I am designing kitchens, Sketchup is still the fastest tool for the job despite it’s limitations.

Try checking split by group in the import options (right side of the import window, geometry tab).


Worked perfectly. Thank you very much for the prompt and detailed response

Hello again,

I’m having an issue with some objects rendering black in Blender. They appear to be items which have been inverted in Sketchup to make a mirror copy of the original. This process seems to mess up the normals, but despite flipping or recalculating the normals, I can’t get the texture to appear. I’ve tried different .obj exporters from Sketchup and the .skp importer for Blender but they all have issues. The best .obj importer within sketchup gives the best overall result except for the black face problem.
Any ideas how to correct this please?