Problem joining meshes

I have created a mesh with a particle system (grass). I’ve converted the particle system, deleted the original mesh and now i’m left with some grass blades. My problem is that when i try to join them by ctrl-j it seems that the whole particle system duplicates - i have no idea what’s happening.

I’m attaching the .blend file with the grass. I would appreciate if someone could explain what happened or joined the blades into one mesh (if the file somehow works fine for you).

Thanks in advance

That file seems to only have different grass meshes.

Starting from the particle system the operation would be: move the emitter to another layer so that the duplicates are on another layer, separate from everything else in the scene. Then select emitter, make duplicates real (ctrl+shift+A or convert), remove particle system from the emitter or the emitter itself, select grass blades, select active selection if there isn’t one (shift+select to deselect/select one) and ctrl+J.

But then it’s probable this wouldn’t be optimal thing to do. When you’re using a particle system, it uses instancing and you’re able to add much more geometry than you would be when making the duplicates real. A subdivision surface modifier for a grass would be an overkill too.

Firstly, thanks for a quick reply.

I did pretty much what you described - i converted the particles, removed the emitter, selected grass blades, selected active selection, pressed control-j and ended up with much more grass blades than before - and this is exacly my problem, I do not want to have more blades than are in the file right now.

The file I uploaded has only grass, since I didn’t want to make people download a large file with stuff that isn’t relevant to the question.

I do not need to modify those blades any more, I need to be able to export the model into Unity as one mesh - there’s arount 1600 objects here and it damages the performance. I know that in a normal case subsurf on grass is overkill, probably grass that is more than a plane would be too much too - but here the case is that the camera is very close to the ground, so the grass takes up about half the height of the screen.

So, if i did not make myself clear before - I need to have the models that are in the file joined into one mesh, and pressing ctrl-j makes more grass blades appear.

By the way, did joining the objects work for you fine? If that’s the case, the problem may be my Blender settings, I thought that the models were linked in some way I did not know of.

this is a repost, since my previous post i made 12 hours ago did not appear on the forums, while a number of other posts have appeared and the thread I started was approved within 1 hour - this leads me to believe that my previous response got deleted. If that is not the case and there is a post made by me awaiting approval in this thread please delete this post.

If this post gets approved, please delete this note.

Thanks for the quick reply.

I did exacly what you told me to do, and what i have now is the file i uploaded - approximately 1600 grass blades as separate objects. What I’m trying to do is to join them together, however pressing ctrl-j gives me weird behaviour. If i try to join two blades a lot of new grass blades appear, when I try to join more Blender crashes.

My question is: What might have caused this issue and how do I fix it? Or at least, where do I start looking? I’ve never seen something like that mentioned in a tutorial and google searches give me nothing useful.

I understand that it will not be possible to easily modify the mesh after i make duplicates real, but I do not wish to change them any more. I use subsurf on the grass because the camera will be close to the ground and without subsurf they look really blocky.

Yes, worked fine.

Left: before joining, Right: after

I don’t see any problems with the joining or didn’t notice anything out of the ordinary. Couldn’t see anything about the settings either. What I suspected was that the particle system you used was still on and it looked like it had more grass but it was just the source (or old version of that). But that doesn’t explain why it would be in the joining part and not before. If the particle system had more grass and only part of it were shown in the viewport, that wouldn’t explain there being more grass just in the joining part.

I can’t find out what could be wrong with the information at hand. What you maybe could try is using particle instance modifier and apply that. The result should be an already joined mesh. Here’s an example

particleinstance_ja12.blend (96.4 KB)