Problem: Particles wrong with time remapping

Hello everybody,

I am having a problem which is driving me crazy.
I have a scene with some different Particle Systems.
When I do not change the time remapping and play the scene in the 3d view and render it everything works fine.
But when I now increase the time remapping factor “new” from 100 to 400. The particle system starts to act very strange.
Sometimes already in the 3d view the particles are flying around like crazy and are not there where they should be. But sometimes the 3d view shows the particles correct.
So but when I now start to render the animation (frame by frame), the rendered image always shows the crazy and wrong particle positions.
But when I just render one image and the particles are at the correct positions.

So if anyone might have an idea or experienced something similar I am really hoping for some advice…

Thanks and Greetings

The particle cache defaults to every 10 frames (I think). You may want to set that to 1. So the cache is updated every frame.

I’m not sure what you mean by time remapping. That is an After Effects term. How do you do that in Blender?

Hi Atom,

thank you for your reply.
I will try your suggestion and give you then feedback.

But here is how you can do time remapping inside Blender:

In the render menu, you can set the time remapping factor.
If old is 100, and you set new to 400, the speed of your animation will be 4 times slower…

Greetings dechgo

Hi Atom,

I did set the Cache Step to 1 and the particles did still not act correct, but it was better then before.
But than I additionally activated “quick Cache”.
And now it seems really to work.

So thank your very much for your suggestion, because I never would have changed anything in the cache settings. Because, to be honest, I do not know what these settings really do :slight_smile:

Greetings dechgo

After rendering a small sequence, I noticed that the particles are still not working correct.
Even if set the cache step to 1 and activate “Quick cache”…

This is really frustrating :frowning:

Greetings dechgo

Hey, have anybody actually fixed the problem? I have just encountered exactly the same issues with Blender 2.5 - when you do time remapping, particles go crazy… Please help.

I don’t think time really works correctly in Blender. At least not the way it works in Cinema4D. In C4D time works correctly. In Blender it just sees to be an after thought. For instance, if I render a 5 second image sequence at 25 fps I get 125 frames rendered. If I up the fps to 50 I still get 125 frames in Blender. In Cinema4D I would get 250 frames @ 50fps because time is actually faster.

There was a tutorial on Time Remapping on Blender Cookie but I can’t seem to find it anymore?

Time remapping seems to work fine but not when particles are involved. Maybe that’s because they have a separate framing params… anyway it’s very frustrating :slight_smile:

I know this is 8 years later, but this is still an issue… I’m very close to the end of my huge animation project, in fact, this is the last issue I’m trying to solve. Well… If it wasn’t solved in 8 years, ill just delete the file and all its backups… :frowning: Lesson learned, make many files, not one big one. Like… 1000 frame animation should be 10 blender files, 100 frames each, so you can edit parts individually, even though it will take 10 times longer. For real though.:rage: rage

I had a similar problem, was able to fix it by setting on cache tab of each individual particle system

  • Caching everything on disk (setting checkbox on Disk Cache)
  • Cache step:1
  • Bake all dynamics
  • Calculate To frame

It is entirely possible that only some of these settings helped and you dont need to set them all - I am quite a beginner, so set stuff that seemed like it could help :slight_smile: