problem to create a manipulator to change the offset of a texture

I’m trying to animate the offset of a texture and I can create keyframe without any problem, the problem is to use a key shape driver.

When I do it, the key become purple, and I see it in the f-curve panel (driver) but even when I set everything right, it’s not working.

On this example, the empty should change the offset, the way it moves the little square, but it does not.

if anyone has a solution, thank you.



texture_offset.blend (364 KB)

No one? Do you think it is a bug?

Don’t know why but I removed driver and created new one and it works. I think something was messed up with data path under Active F-Curve tab in driver editor.


texture_offset.blend (394 KB)

cool! thank you very much jawra!

hey jawra, I tried several ways and it’s still not working, go you give me a walk through on how you did it.

Thank you very much!


In your file I’ve just deleted driver.There is a button ‘RemoveDriver’, then AddSingleDriver over texture’s X-Offset.
In Graph/driver editor set object to Empty, AveragedValue instead of ScriptedExpression and that’s it.
There are differences you can compare in data path of driver but it’s generated automatically.
Word about texture: I had to rotate UV map 180 deg. to make texture following Empty’s direction.
Do you use latest build? I do so.

ok, so I downloaded the latest version and recreated the driver the same usual way and it worked! on the version r35555
the only thing is that the value in the texture panel doesn’t change to the purple color… which is not a big deal but if you don’t know that could be confusing for those who want to change the value manually… :stuck_out_tongue:

thank you so much jawra… so it seems that it was a bug fixed in the latest version.

I think there is a bug. No color indicator is not big deal but Paths are completely broken. I think so. Try this: add driver via RMB menu - driver is added, then do it one more time - there should be no AddDriver entry but it is!
I’m gonna report it after tests.

true, even when I added a driver, it is still possible to add one but you don’t have the option to delete it.


thank you jawra!


here’s how i see it the data_path that is created and animated is in context with the panel you keyframe from, in your example texture x offset is the path from the material, whereas the path material_slots… blah …offset is a path from an object base. You get the same thing for instance if you animate the evalution time of a curve… the fcurve that is created is in context to the curve objects data… not the curve object… so as soon as you go to the action editor you break context… and get a bag of red underlines.

One way to fix is to write a script to fix the data_path of the fcurve to give it object base if you are going to edit it in the action editor.

Things got changed some time ago, so we have to wait for proper solution. Explanation here: