Problem when rendering fire.

Hi! My problem is as follows:

when seeing the fire animation in Blender it works just fine.

My problem’s when I render it. A bothersome plain black square appears beneath the fire.

I’m following this tutorial, and it’s alright until I have to render for the first time. According to the video it should be a purple fire, but there’s no black square under it. I followed it up to 4:20.

At first even the fire didn’t render. I even tried to set the Domain Cube’s Textures’ Mapping Coordinates to “Generated”, the fire appeared, but that black square didn’t disappear.

When there’s no simulation going on there’s no black square:

I just hope you could tell me what I’m doing wrong, or what to do to get it right.

My Blender version is 2.75 and I’m running it in Windows 7 64 Bits with an NVidia 760.

Thanks in advance for your time!

I forgot to mention, but my Blender version is 2.75. Again, thanks for your time!

Down on the bottom on Material tab for the ground - Shadow - Receive Transparent should be checked. Is it?

It renders correctly now! Thank you very much! And sorry for being such a noob :spin:!

It renders correctly now! Sorry for being such a noob XD! Thanks again :)!

Hi! It’s me again! Now the one not rendering’s the fire inside the furnace. All materials surrounding the fire have “Receive Transparent” checked. The procedure was copying the two objects from the hearthfire and duplicating materials and textures, such as adding “.Furnace” behind the new materials and textures. I’ve been two hours trying to figure something out but to no avail :’(.

I hope someone knows what I’m doing wrong T.T. Thanks again and have a great Wednesday!

No sorries, there are a lot of things to loose in a process. Things happen ;).

This time however i’m out of crystal balls. You’d need to make a file where minimum things to show the problem are present and post it on, preferably, or any other place on i-net without annoying adds and such. Post link here and you’ll get it working in a no time.

The file’s too big for Pasteall, sorry. I’ve uploaded it to Google Drive, here’s the link (it’s around 50 MB):

And thanks a lot for helping me out :D!

I’ve already solved the problem. It was me not paying enough attention :(. When I copied the objects and textures some settings were turned off. I’ve noticed some hours ago, so I’ve turned them on and now I’ve got a working furnace :yes:! Now I’ve just gotta figure out how to make the smoke go out through the lateral hole XD.

And yet again, thanks for your time :)!

Late back here… Anyways, glad you’ve solved this.