Problem with ambient? (lights)?...


I would like to preface this message by saying I have searched this board extensively about this subject, so if this question has been solved I apologize for any inconvenience. Like many people have asserted in many recent versions of blender, there has been a common problem in the game engine. There is an error that occurs on blenders default scene that causes the default cube or any polygonal object for that matter to “appear” to be illuminated, or lightened with or without the presence of any light source in the scene. There is a discrepancy between the values seen on an object in and out of game mode. To clarify this lets set up a scenario:

  1. Default scene, sphere with default material, 1 point light illuminating the sphere.
  2. Texture mode. The shadow areas of the sphere are extremely dark.
  3. Press “P” entering game mode, and now the whole object is much lighter as if the values have been blanched.

…Simple enough? So…

My question is what is going on??:no: I have been using Blender for many years and never until recently have i had this problem. In the past, I have made test games with very dark rooms, and the values in “viewport/texture mode” and game exactly matched. In addition, i must make clear that i have tried the most current version of blender at the time this problem occured, and 5 or so older versions, and i still have the same issue. Just in case, I have tried…

  1. Checking and unchecking blender materials in the game menu in info bar
  2. Removed all ambient values under the value slider in materials section.
  3. Adjusted ambient RGB Values under World settings.
  4. Turned down emit value to 0.

After all that I even removed all object lights from the scene, and in texture mode press P and guess what happened? My object is a solid light grey color, and yes I made sure that light is applied to all faces, and i even made the vertex colors solid black to ensure they had no possible influence. I dont think missed anything, but im sure i did. Still, I’m both frustrated and baffled by what “seems” to be a lack of information or interest about this issue, or a complete misconstruction of this problem. Sorry for the long post, but i felt it warranted further explanation. Please refer to the images below, and thank you for your continued support.


I don’t see this in my setup. The viewport shading is the same as in game mode. I presume you are using GLSL materials? Possibly a graphics driver issue. Post a .blend file.

Thank you for the reply jrboddie1. I’m not sure about GLSL, but it’s possible, and thank you. It’s probably a graphics card issue like you suggested, ill look into it. Here’s the blend. Please let me know if you are able to figure anything out. Thanks again.:slight_smile:


ambient.blend (783 KB)

It looks fine on my computer as well. I messed with some settings and it still looks fine, I even moved the ambiant light sliders around. I think its your computer.

Hey thanks guys. I kind of suspected so. Thanks for all your help. I probably should just get a new graphics card. Im a windows xp user, could anybody make any recommendations? I’ve heard people have had trouble with ATI. thanks again

In the Game Menu, change from Texture Face Material to Blender GLSL Material and see if that makes a difference for you.

Also, I believe that in the World panel, you should try setting Range to 1.0.

(If you change cards, I recommend NVidia.)

On my Windows XP (with crappy Intel video) I have a similar problem.
Under the Game menu, if you select Blender Multitexture Materials, the problem is much less. It still doesn’t match the preview exactly, but at least it doesn’t add a lot of ambient light.

Thanks for the replies and help everyone. In spite of all the suggestions-which are very welcomed and appreciated- I finally found a solution. I downloaded blender 2.40 and voila, no ambient problem. The values of the preview match the in game values. Not sure why this happens on some versions and only a few it doesn’t. Thanks!