Problem with bevel...

Another noob difficulty in here…

I am currently creating a Power Up item. for and old game remake. That´s easy, I just covered a background image . After that, I extruded the drawn image and finally transformed the front and backfaces (all three letters) into a full polygon… but, when I try to bevel it, some weird faces appear, just kind of “scars” in the mesh.

Any tips of what might be going wrong? :frowning:


It looks like you built the outline as a mesh and then auto generated the front and back faces?

you probably won’t get a clean mesh that will bevel well this way.

you could go back and subdivide your edges manually so you stay away from triangles, or you could build the outline of the letters as a curve object.

going with a curve allows you to extrude and bevel it without changing to a mesh.

curves are my favorite part of blender, well worth learning!:yes:

Uhm, well…curves are not my favorite part of Blender but they do work. In this case they might be worth a shot but this is nothing which couldn’t be solved with poly modelling.

So, as he stated, you should try and make faces manually, before applying a bevel or anything. When you have the outline done (the 2-dimensional one), simply select four vertices at a time and hit F to make a face. Again, as he said, try to avoid traingles but judging from the screenshot, you will need to use some at certain places.
Then, I’d suggest doing the bevel manually. When you have the 3-dimensional shape, select all the vertices of one side and extrude, then scale down a little (maybe using Alt+S). Yes, there is a bevel tool, but even if you have a clean mesh, you won’t have one anymore after using the built-in bevel. Try it, but it might not work out well.

A bit offtopic:
what’s the name of the game? As far as i remember it’s a mario game, lots of fun :smiley:

The game is a remake of Commando Tracer / The Last Commando. A spanish game for 8-bit computers.

Thanks for the tips. I’ll try them ASAP. :slight_smile:

Still can’t get it. I did the “POW” letters with Bezier curves, but when I select all the vertexes and try to extrude it, Blender simply doesn’t extrude. :frowning:

There’s two ways to extrude bezier curves.

  1. In the Edit menu (F9) there’s a extrude setting. Alter here.

  2. Switch to object mode, go to scale manipulator mode, which is ctrl + alt + s, then with the left mouse button grab the axis and drag it out.
    To see how much it has extruded, Hold down the alt key and left mouse button and rotate around your object.

A Curve does not have vertices and commands like extrude work differently with meshes and curves. As iamthwee said, curves can be extruded in their Curve and Surface Tab.

I found how to extrude the curves (had I connected to the Internet later, I’d have read your replies). Anyway, I finally used curves and extruded the image. It worked fine for what I wanted. Thanks once again. :slight_smile: