Problem with Bones!

I have a bit of a problem…

here it is:…&v=1t1mlPZYg3I

(That vid was made for somebody else (Ran13). so u will hear me reference the fact that i have talked to him before. just sayin that so it dosen’t get confusing)

I’m thinking you have bone envelopes on in addition to vertex groups. If you select the model, look at the armature modifier, make sure the Use Envelopes is unchecked. Also, dotted black line just points to bone parent. Can be disable in 3d views properties panel.

OK, well didn’t feel like waiting for the download, anyways, like danield says the problem (mostly) with your wing deformation is that the armature modifier option “use envelopes” is most likely on, as far as the stray vertex goes an easy way to find it is to go to the armature modifier panel (turn off envelopes :wink: ), and enable the deformation in edit mode (third button to the right of armature modifier name) then go into edit mode after deforming the wing and finding the stray vert, since you didn’t get it when weight painting you can either select the vertex group that the vert should be apart of, selecting those vertices, you then select the stray and click assign, this should fix the problem. also there is a good chance that the vertex isn’t supposed to be there anyways so you can probably get away with just deleting it.

Bone envelopes are allready off :frowning: (proof:

Bone envelopes are allready off :frowning: (proof:

also, i turned on “enable the deformation in edit mode” and when i moved the bone in edit mode it didn’t work!?!?!?!??!
I offer cookies to anyone who can figure this out…

If you upload the file into forums ill dl it and check it out, just use attachments

I attached it!

Ill check it out

The rig should have its bones named for left and right but simply naming a bone RightWing or LeftWing won’t work, what i would suggest is wing.01.L, wing.02.L etc, replacing L with R when you are making the right side, this way you can flip poses from one side to another when you are animating and when you use weight painting the option for mirror weights will properly work.

As far as the stray vert goes, you actually have another bone influencing those verts, rotate the lowerspine bone to see this happening, this can be fixed with proper weight painting, also the reason why the mesh went back after you entered edit mode is because you need to also select the additional button that appears when you enable use in editmode (little triangle :wink: )

Additionally those stray verts can safely be deleted, and i think some mesh cleanup is in order :slight_smile:

I hope this helps let me know if you have any more problems.

oh, btw you going to want to either delete all the vertex groups and reassign the mesh after you have renamed the bones or rename them manually to reflect the bones. I’m not exactly sure that it is required because my vertex groups have always been the same name as the bones that control them, so it is possible that it will still work fine but it can be a bit confusing.

is the “wing.01.L” thing a matter of style, or will it acctuly affect somthing?

Okay, so basicly, just re-do all the vertex groups?

P.S also, the name of the bone HAS to be the same as it’s vertex group. u can’t change it. if u edit the name of the bone, it edits the name of the vertex group. Or i could be compleatly wrong.

P.P.S is the “wing.01.L” thing a matter of style, or will it acctuly affect something??